Bug 533322 - When creating a new book with Publican it cannot be built
When creating a new book with Publican it cannot be built
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Joshua Wulf
:
: 537743 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-05 23:20 EST by Isaac Rooskov
Modified: 2015-07-13 00:49 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-10 00:13:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Isaac Rooskov 2009-11-05 23:20:02 EST
Description of problem:
After running the create command for publican, the publican.cfg file contains blank properties, which mean the book cannot be built.

Version-Release number of selected component (if applicable):
1.2

How reproducible:
100%

Steps to Reproduce:
1. Run the command: publican create --name Test --lang en-US --version 3.0 --edition 1.0 --product JBoss Developer Studio --brand JBoss
2. Build the book with the command publican build --formats html,html-single,pdf --langs en-US
3. Build fails
  
Actual results:
The following error is produced:

Invalid format for docname. Value (ARRAY(0xa4dc728)) does not conform to constraint ([^a-zA-Z_\-0-9.]) at /usr/bin/publican line 366

Expected results:

The build succeeds

Additional info:

The parameters causing the error in the publican.cfg file are:
docname
version
edition
product
Comment 1 Jeff Fearn 2009-11-06 00:38:20 EST
This was cause by empty fields being added to the publican.cfg file. Modified code to delete empty elements correctly.

The real bug is probably in Config::Simple which should not be choking on empty fields, I'll try and track it down when I get some free cycles.

Also note that your productname field in Book_Info.xml is probably not what you want. This is due to the white space, so you need to add quotes around the name.

e.g. --product "JBoss Developer Studio"

Cheers, Jeff.
Comment 2 Ruediger Landmann 2009-11-16 07:23:12 EST
*** Bug 537743 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2009-12-07 21:14:35 EST
publican-1.3-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.3-0.fc12
Comment 4 Fedora Update System 2009-12-07 21:17:57 EST
publican-1.3-0.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.3-0.fc11
Comment 5 Fedora Update System 2009-12-09 23:13:34 EST
publican-1.3-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-12-09 23:26:25 EST
publican-1.3-0.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.