Bug 537743 - Enhancements to creating a publican book from scratch.
Enhancements to creating a publican book from scratch.
Status: CLOSED DUPLICATE of bug 533322
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-16 01:16 EST by Jared MORGAN
Modified: 2015-08-09 21:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-16 07:23:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jared MORGAN 2009-11-16 01:16:13 EST
Description of problem:

When you create a new publican book, you have to edit the .cfg before you can publish it.

The default files are also not nested in a human-readable form.

Version-Release number of selected component (if applicable):

[jmorgan@jmorgan en-US]$ rpm -qi publican
Name        : publican                     Relocations: (not relocatable)
Version     : 1.1                               Vendor: Fedora Project
Release     : 0.fc11                        Build Date: Tue 03 Nov 2009 05:54:29 AM EST
Install Date: Mon 09 Nov 2009 09:47:12 AM EST      Build Host: ppc2.fedora.redhat.com
Group       : Applications/Publishing       Source RPM: publican-1.1-0.fc11.src.rpm
Size        : 1263877                          License: (GPLv2+ or Artistic) and CC0
Signature   : (none)
Packager    : Fedora Project

How reproducible:

100%

Steps to Reproduce:
1. Execute "publican create --name publican_base_publish --lang en-US --product JBoss_Middleware
2. Execute "cd publican_base_publish"
3. Execute "publican build --formats=html-single --langs=en-US"
  
Actual results:

The following error message is displayed:

Invalid format for docname. Value (ARRAY(0xafd5ac4)) does not conform to constraint ([^a-zA-Z_\-0-9.]) at /usr/bin/publican line 362


Expected results:

The book should publish using the default values configured when you build the book.

Additional info:

The publican.cfg file has extra parameters added which are left blank.  Removing these manually and republishing will result in a successful publish.
Comment 1 Ruediger Landmann 2009-11-16 07:23:12 EST

*** This bug has been marked as a duplicate of bug 533322 ***

Note You need to log in before you can comment on or make changes to this bug.