Bug 533352 - Volume jumps up for remainder of audio buffer when exiting a music player
Summary: Volume jumps up for remainder of audio buffer when exiting a music player
Keywords:
Status: CLOSED DUPLICATE of bug 525882
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-06 10:43 UTC by Kieran Clancy
Modified: 2009-11-10 02:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-10 02:47:32 UTC
Type: ---


Attachments (Terms of Use)

Description Kieran Clancy 2009-11-06 10:43:36 UTC
Description of problem:
Whenever I am playing music and quit without stopping the music first, there will be an audible jump in volume for a fraction of a second while the audio stops playing. This occurs with totem, mplayer, etc. I think it only happens when I set the player/stream volume to less than maximum. My hunch is that pulseaudio notices the application has closed, resets the main volume to whatever it was before that application had changed it, but doesn't think to attenuate or clear any audio currently in the buffer.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.15-17.fc11.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Set master volume really high
2. Start playing a music file, but set the volume really low in the client
3. Exit the client
  
Actual results:
Audio stops promptly with no volume spike.

Expected results:
Loud spike in volume. With some audio files this can give me quite a surprise.

Comment 1 Kieran Clancy 2009-11-06 10:49:16 UTC
I should also mention; this occurs when skipping a track in totem too, not just on exit. Possibly due to totem creating a new PA stream?

Comment 2 Lennart Poettering 2009-11-10 02:47:32 UTC

*** This bug has been marked as a duplicate of bug 525882 ***


Note You need to log in before you can comment on or make changes to this bug.