Bug 533797 - autopartition doesn't handle correctly installation where the default layout leads to bigger partitions than disk available
Summary: autopartition doesn't handle correctly installation where the default layout ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 538229 557389 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-09 09:15 UTC by Arenas Belon, Carlo Marcelo
Modified: 2010-02-23 19:53 UTC (History)
3 users (show)

Fixed In Version: anaconda-13.8-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-23 19:53:07 UTC
Type: ---


Attachments (Terms of Use)
traceback report (113.91 KB, text/plain)
2009-11-09 09:15 UTC, Arenas Belon, Carlo Marcelo
no flags Details
proposed workaround for anaconda 12.46 (or later) (1.02 KB, patch)
2009-11-09 09:42 UTC, Arenas Belon, Carlo Marcelo
no flags Details | Diff

Description Arenas Belon, Carlo Marcelo 2009-11-09 09:15:59 UTC
Created attachment 368148 [details]
traceback report

Description of problem:
This is a subcase of BUG523610 where the disk available for installation is smaller than

Version-Release number of selected component (if applicable):
12.46-1

How reproducible:
Always

Steps to Reproduce:
1. create a 2GB volume for use through KVM
2. install fedora on it using a VM with 1G or more of memory allocated
3. select all defaults
  
Actual results:
an unhanded exception triggered that abort anaconda

Expected results:
autopartition works or shows a message to let the user do partitioning manually

Additional info:
the problem is that when autopartitioning is invoked the setDefaultPartitioning method in installclass.py will request for a root partition of 1GB, one /boot partition (outside of LVM) of 200MB and a swap partition of at least the same size of the memory, without taking into consideration the size of the physical devices available.

this will result in a negative value for vg.freeSpace for the main VolGroup which will break when passed to storage/partition.py's growLVM

Comment 1 Arenas Belon, Carlo Marcelo 2009-11-09 09:42:52 UTC
Created attachment 368152 [details]
proposed workaround for anaconda 12.46 (or later)

to easy testing, a patched anaconda 12.46 based updates.img available from :

  http://sajino.sajinet.com.pe/updates.img

Comment 2 David Lehman 2009-11-12 17:26:44 UTC
A fix will be in anaconda-13.8. Thanks for the report.

Comment 3 Bug Zapper 2009-11-16 15:20:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 David Lehman 2009-11-18 15:54:06 UTC
*** Bug 538229 has been marked as a duplicate of this bug. ***

Comment 5 David Lehman 2010-02-04 23:37:49 UTC
*** Bug 557389 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.