Bug 533959 - Firefox crashes with Flash plugin, using Firefox from Fedora (NOT downloaded from elsewhere)
Firefox crashes with Flash plugin, using Firefox from Fedora (NOT downloaded ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
11
All Linux
high Severity high
: ---
: ---
Assigned To: Kai Engert (:kaie)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-09 16:42 EST by Kai Engert (:kaie)
Modified: 2013-02-01 10:11 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 11:25:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kai Engert (:kaie) 2009-11-09 16:42:16 EST
This is spun-off from bug 505365.
Bug 505365 is for users who download Firefox from mozilla.com.

This bug is for users who strictly use firefox.rpm from Fedora, only.


Many people have reported they crash using firefox.x86_64.rpm from Fedora, combined with a 64 bit flash plugin from Adobe. At this point I assume this crash is caused by a deficiency in the flash software, but it hasn't been confirmed yet.

The suspicion is based on the fact that many flash sites work (simple videos on the youtube site), only some flash content triggers the crash, like:
http://www.youtube.com/falltvpreview


If you are using a 32 bit firefox.rpm from Fedora with a 32 bit flash plugin, and crash on flash content, please speak up.
Comment 2 Vassilios Kotoulas 2009-11-10 15:50:12 EST
Not only firefox, but any browser I use is crashing with flash which contains sound. flash without sound works mostly

[root@kra:~] uname -a && rpm -qa firefox\* xulrunner\* nss\* nspr\* flash-plugin\*
Linux kra.bla.fasel 2.6.30.9-96.fc11.i586 #1 SMP Tue Nov 3 23:33:04 EST 2009 i686 i686 i386 GNU/Linux
nspr-4.8.2-1.fc11.i586
nss_compat_ossl-0.9.5-3.fc11.i586
nss_ldap-264-2.fc11.i586
firefox-3.5.5-1.fc11.i586
nss-devel-3.12.4-3.fc11.i586
nspr-devel-4.8.2-1.fc11.i586
nss-3.12.4-3.fc11.i586
flash-plugin-10.0.32.18-release.i386
xulrunner-1.9.1.5-1.fc11.i586
nss-mdns-0.10-7.fc11.i586
nss-softokn-freebl-3.12.4-3.fc11.i586
nss_db-2.2-44.fc11.i586

after this I installed nspluginwrapper. now the browser doesn't crash anymore, but flash with sound doesn't work, the window stays grey and syslog say something like this:

kernel: npviewer.bin[19277]: segfault at 0 ip 006689fb sp bff6ae00 error 4 in ld-2.10.1.so[65e000+20000]
Comment 3 Bruno RAMEY 2009-11-14 03:11:46 EST
I have this problem :

my PC is 32 bit :
[bruno@localhost ~]$ uname -ar
Linux localhost.localdomain 2.6.30.9-96.fc11.i586 #1 SMP Tue Nov 3 23:33:04 EST 2009 i686 athlon i386 GNU/Linux

all the stuff came from fedora/rpmfusion :
[bruno@localhost ~]$ rpm -qa firefox\* xulrunner\* nss\* nspr\*
nss-3.12.4-3.fc11.i586
xulrunner-1.9.1.5-1.fc11.i586
firefox-3.5.5-1.fc11.i586
nss-softokn-freebl-3.12.4-3.fc11.i586
nss_compat_ossl-0.9.5-3.fc11.i586
nss_ldap-264-2.fc11.i586
nss-tools-3.12.4-3.fc11.i586
nss_db-2.2-44.fc11.i586
nspr-4.8.2-1.fc11.i586

Flash was installed from Adobe repository :
[bruno@localhost ~]$ rpm -qa flash\*
flash-plugin-10.0.32.18-release.i386

nspluginwrapper is NOT installed

I don't know if it is important or not : I have a file libflashsupport that was installed with Adobe reader. I don't know if it used with Firefox (I don't know how to know !)
[bruno@localhost ~]$ locate libflash
/opt/Adobe/Reader9/Reader/intellinux/lib/libflashsupport.so
/usr/lib/flash-plugin/libflashplayer.so
/usr/lib/mozilla/plugins/libflashplayer.so
/usr/lib/openoffice.org/basis3.1/program/libflashli.so

As written in the first comment, some flash site work and other crash Firefox.
few times with www.ebay.fr, more often with www.lefigaro.fr


important : 
1) I'm French ! It's a long way to have a perfect English !
2) I'm new with bugzilla ! but you can ask me to do things ! as far as I can
Comment 4 Carlo de Wolf 2009-11-17 04:07:07 EST
$ uname -a && rpm -qa firefox\* xulrunner\* nss\* nspr\* flash-plugin\* libflash\*|sort
Linux nymph.grauwnet.nerdnet.nl 2.6.30.9-96.fc11.i586 #1 SMP Tue Nov 3 23:33:04 EST 2009 i686 i686 i386 GNU/Linux
firefox-3.5.5-1.fc11.i586
flash-plugin-10.0.32.18-release.i386
nspr-4.8.2-1.fc11.i586
nspr-devel-4.8.2-1.fc11.i586
nss-3.12.4-3.fc11.i586
nss_compat_ossl-0.9.5-3.fc11.i586
nss_db-2.2-44.fc11.i586
nss-devel-3.12.4-3.fc11.i586
nss_ldap-264-2.fc11.i586
nss-softokn-freebl-3.12.4-3.fc11.i586
nss-tools-3.12.4-3.fc11.i586
xulrunner-1.9.1.5-1.fc11.i586
Comment 5 A. Folger 2009-11-19 10:22:06 EST
I have the same general, but the details differ.

First of all, flash sound works for me (when FF doesn't crash). Then, it religiously crashes on some sites using flash. Emphasis on some. I can access and use YouTube all right, but others cause an immediate crash of XWindow, so that I go back to the kdm/gdm,xdm login screen or to the console.

An example of a site where I crash every time, though sometimes only after a refresh, is http://www.responsa.co.il/default.aspx. I know that most testers will have trouble using it, as it is meant for querying Hebrew texts, but the interface is [available] in English, and since in 99% of cases it crashes immediately, it should be possible to debug without actually using the functions the site offers.

Finally, I noticed some additional weirdness:

* I am using an ATI Radeon 9200SE graphics card. Up until Fedora 10, everything was great; I used the flglx driver. That driver no longer supports my card, so I am now using the radeon driver. All the above problems occur when I use the radeon driver. However, if I configure Xorg to use the vesa driver, Firefox+flash no longer crashes on the problematic web sites. However, that is only a short term solution, as the vesa driver is slow.

* Firefox can grok the flash all right, as it only crashes when the tab with the problematic web site is visible. If I load the tab in the background, FF will load it properly. However, as soon as I select the tab with the problematic web site, the whole house comes down.


I should note that problems started appearing in Fedora 11, when FF would sometimes lock up the screen and keyboard and mouse, necessitating a reboot. However, it was happening more rarely then, so I did not previously file a bug report on that issue. Now, on the other hand, it prevents my normal work.


The files I have installed:
===========================
$ uname -a && rpm -qa firefox\* xulrunner\* nss\* nspr\* flash-plugin\* libflash\*|sort
Linux localhost.localdomain 2.6.31.5-127.fc12.x86_64 #1 SMP Sat Nov 7 21:11:14 EST 2009 x86_64 x86_64 x86_64 GNU/Linux
firefox-3.5.5-1.fc12.x86_64
flash-plugin-10.0.32.18-release.i386
nspr-4.8.2-1.fc12.i686
nspr-4.8.2-1.fc12.x86_64
nss-3.12.4-14.fc12.i686
nss-3.12.4-14.fc12.x86_64
nss_compat_ossl-0.9.5-4.fc12.x86_64
nss_db-2.2-45.fc12.x86_64
nss_ldap-264-8.fc12.x86_64
nss-mdns-0.10-8.fc12.i686
nss-softokn-3.12.4-10.fc12.i686
nss-softokn-3.12.4-10.fc12.x86_64
nss-softokn-freebl-3.12.4-10.fc12.i686
nss-softokn-freebl-3.12.4-10.fc12.x86_64
nss-tools-3.12.4-14.fc12.x86_64
nss-util-3.12.4-8.fc12.i686
nss-util-3.12.4-8.fc12.x86_64
xulrunner-1.9.1.5-1.fc12.x86_64
Comment 6 Eddie Lania 2009-11-22 14:37:53 EST
Blacklisted package?

Nov 22 20:24:56 p3000fedora kernel: npviewer.bin[2716] general protection ip:136d04c sp:bfb3ab10 error:0 in libflashplayer.so[ffd000+990000]
Nov 22 20:24:56 p3000fedora abrtd: Directory 'ccpp-1258917896-2716' creation detected
Nov 22 20:24:56 p3000fedora abrtd: Lock file '/var/cache/abrt/ccpp-1258917896-2716.lock' is locked by process 2736
Nov 22 20:24:57 p3000fedora abrt: saved core dump of pid 2716 to /var/cache/abrt/ccpp-1258917896-2716/coredump
Nov 22 20:24:57 p3000fedora abrtd: Blacklisted package
Nov 22 20:24:57 p3000fedora abrtd: Corrupted or bad crash, deleting...
Nov 22 20:25:12 p3000fedora abrtd: Getting crash infos...
Nov 22 20:26:15 p3000fedora abrtd: Creating report...
Nov 22 20:26:15 p3000fedora abrtd: Getting local universal unique identification
Nov 22 20:26:15 p3000fedora abrtd: Getting local universal unique identification
Nov 22 20:26:24 p3000fedora abrtd: Creating report...
Nov 22 20:26:24 p3000fedora abrtd: Getting local universal unique identification
Nov 22 20:26:24 p3000fedora abrtd: Getting local universal unique identification
Comment 7 Vassilios Kotoulas 2010-03-04 15:54:53 EST
The problem is solved for me ... it was a strange solution.

I wanted to try firefox from mozilla.org so I installed 3.6. On the first run firefox did its plugin registration/check/whatever. This didn't help so I decided to stay with firefox from fedora  and restarted 3.5.8 which did a plugin registration again. Suddenly flash worked with sound.
Comment 8 Gene Snider 2010-03-09 13:55:59 EST
Firefox doesn't crash for me, but yesterday's .xsession-errors is large!
-rw-------. 1 gene gene 1616827 Mar  9 10:26 .xsession-errors.save

[gene@Mobile-PC ~]$ grep 'firefox.*XID collision' .xsession-errors.save | wc -lc
  25783 1572763

As you can see, most of the file consists of 25,783 instances of that error FF XID error.  This is a fully updated F13 install, with FF from fedora, and 64 bit flash from Leigh's flash repo.  Here's my file list:

[gene@Mobile-PC ~]$ uname -a && rpm -qa firefox\* xulrunner\* nss\* nspr\* flash-plugin\* libflash\* | sort
Linux Mobile-PC 2.6.33-8.fc13.x86_64 #1 SMP Fri Mar 5 13:18:00 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
firefox-3.6.1-1.fc13.x86_64
flash-plugin-10.0.45.2-1.x86_64
nspr-4.8.4-1.1.fc13.x86_64
nss-3.12.6-1.2.fc13.x86_64
nss-softokn-3.12.4-15.fc13.x86_64
nss-softokn-freebl-3.12.4-15.fc13.x86_64
nss-sysinit-3.12.6-1.2.fc13.x86_64
nss-tools-3.12.6-1.2.fc13.x86_64
nss-util-3.12.6-1.fc13.x86_64
nss_compat_ossl-0.9.6-1.fc13.x86_64
nss_db-2.2.3-0.2.pre1.fc13.x86_64
nss_ldap-264-9.fc13.x86_64
xulrunner-1.9.2.1-1.fc13.x86_64

Is there anything I can post to help nail this down?

Gene
Comment 9 Bug Zapper 2010-04-28 07:11:29 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2010-06-28 11:25:46 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.