Bug 534750 - (RHQ-1516) be able to uninventory or ignore services
be able to uninventory or ignore services
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
1.3.1
All All
high Severity medium (vote)
: ---
: ---
Assigned To: Charles Crouch
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
Depends On:
Blocks: jon24-search
  Show dependency treegraph
 
Reported: 2009-02-09 18:45 EST by John Mazzitelli
Modified: 2015-02-01 18:25 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-14 13:23:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2009-02-09 18:45:00 EST
There is currently no way to uninventory or ignore services (either platform services or services under servers).

Consider implementing the ability to do this.
Comment 2 jlrodr 2009-07-14 08:51:23 EDT
all monitoring sofware can uninventory components. In jon can't taken this. Don't should be there?
Comment 3 John Mazzitelli 2009-07-14 08:59:04 EDT
That's why this issue exists :) Need to implement. There is a "secret" way to do this now IIRC - in the URL, you put "?debug=true" and the uninventory button is enabled.  However, its not available normally because under normal conditions (i.e. if the service really does still exist on the agent side) then the agent will rediscover the service and commit it back into inventory automatically, undoing the uninventory that was just performed.

This issue is to document the need to be able to tell the agent, "ignore this resource, even if you discover it again". Right now, only servers can be igonred, not child services.
Comment 4 Red Hat Bugzilla 2009-11-10 15:34:45 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1516
This bug is duplicated by RHQ-2173
Comment 5 wes hayutin 2010-02-16 12:08:53 EST
mass add of key word FutureFeature to help track
Comment 7 Charles Crouch 2010-03-31 13:53:48 EDT
Another instructive discussion on the issue
http://community.jboss.org/message/534970
Comment 8 Charles Crouch 2010-04-27 12:08:36 EDT
*** Bug 568917 has been marked as a duplicate of this bug. ***
Comment 12 John Mazzitelli 2011-03-25 14:44:25 EDT
in the new GWT interface, you can uninventory resources.

However, the still-outstanding issue is how to IGNORE services.

Because I may want to uninventory, say, my CPU services because I don't want to monitor them. However, the next time we run a service scan, they will be re-discovered and automatically re-inventoried.

We need a way to "ignore" service resources (just like we can for servers) so they are not re-imported into inventory, even if they exist.
Comment 13 Larry O'Leary 2011-03-28 17:40:29 EDT
Just my two cents... I would suggest that we leverage a consistent way to import, remove, discovery, and ignore all resources whether platform, server, or service.

For example, the Auto-Discovery Queue would be a nice way to "ignore" any resource that you do not want in inventory and still give the user a way of un-ignoring it later. I would also suggest that we expand the auto-discovery queue to support discovery invocations and auto-import functions. For example:

Filter by COMMITTED resources:
   Select one or more COMMITTED resource and "Perform Child Resource Discovery"

Filter by COMMITTED resources:
   Select one or more COMMITTED resource and enable/disable "Auto Import Child Resources"

Filter by NEW resources:
   Select one or more NEW resources and enable/disable "Ignore This Resource"

Also, with such functionality, it may be useful to add resource types of Platform, Server, and Service to the filter capabilities.

And while we're at it, maybe get rid of the Auto-Discovery Queue and move this to the actual resource pages with an added filter for the resource's inventory state (COMMITED, NEW, etc).
Comment 14 John Mazzitelli 2013-05-14 13:23:22 EDT
(In reply to comment #12)
> in the new GWT interface, you can uninventory resources.
> 
> However, the still-outstanding issue is how to IGNORE services.
> 
> Because I may want to uninventory, say, my CPU services because I don't want
> to monitor them. However, the next time we run a service scan, they will be
> re-discovered and automatically re-inventoried.
> 
> We need a way to "ignore" service resources (just like we can for servers)
> so they are not re-imported into inventory, even if they exist.

we can now ignore services, too. this has recently been added as a feature. I think we can close this BZ.

Note You need to log in before you can comment on or make changes to this bug.