Bug 568917 - JON241: After using Manually Add - Script to a JBossAS5 resource, the child resource cannot be deleted.
JON241: After using Manually Add - Script to a JBossAS5 resource, the child r...
Status: CLOSED WORKSFORME
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.0
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Lukas Krejci
John Sefler
: Reopened
Depends On:
Blocks: 725852 jon-sprint10-bugs jon241-bugs
  Show dependency treegraph
 
Reported: 2010-02-26 17:24 EST by John Sefler
Modified: 2013-08-31 07:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 652646 (view as bug list)
Environment:
Last Closed: 2013-08-31 07:05:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2010-02-26 17:24:50 EST
Description of problem:
After using Manually Add - Script to a JBossAS5 resource, the child resource cannot be deleted.

Version-Release number of selected component (if applicable):
JON23


How reproducible:


Steps to Reproduce:
1. From within an inventoried JBossAS5 server...
2. Goto INVENTORY / OVERVIEW
3. Manually Add -Script
     create a dummy.sh script on the patform of the JBossAS5 server and enter the Path to it.
4. Now that the script has been successfully added as a child resource....
5. Try to DELETE it...
  
Actual results:
  There is no checkbox next to child resources of type "Script".
  Moreover, because you cannot uninventory a service, there is no way to
  get rid of the inventoried child resource script service.

Expected results:


Additional info:
https://tcms.engineering.redhat.com/case/7891/?from_plan=792
Comment 1 Charles Crouch 2010-04-27 12:08:36 EDT
This is specific case of https://bugzilla.redhat.com/show_bug.cgi?id=534750
Closing as a duplicate

*** This bug has been marked as a duplicate of bug 534750 ***
Comment 2 John Sefler 2010-05-11 16:27:41 EDT
I do NOT believe that this is a duplicate of bug 534750.
Bug 534750 has to do with uninventory/ignore of services.  That means that the service still exists on the platform, but for some reason you do not want the RHQ server to pay attention to it.

This bug is concerned with "Deletion" of a child resource from disk.  In this defect, after manually adding a child resource (a Script) to the inventory of a JBossAS5, there is no way to "Delete" it.  The GUI needs is missing the checkboxes next to the scripts.  Once the checkboxes are there, I expect that the manually added scripts can be checked and 'Delete'd.  The result will be that the script is 'rm' from the file system.

Re-opening this defect...
Comment 3 Lukas Krejci 2010-11-12 07:47:32 EST
commit 118963a293ce0e6682d6cc951e9354dbd1bc8f60
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Fri Nov 12 13:19:25 2010 +0100

    BZ 568917 - Enable creation of as5 scripts by uploading them to the server's bin. Also added support to delete arbitrary script.
    Only scripts with the supported file extensions can be successfully deployed so that they are auto-discovered later and thus appear in the inventory after their uploading.
Comment 4 Lukas Krejci 2010-11-15 13:08:58 EST
This needs to be worked on some more...
Comment 5 Lukas Krejci 2010-11-18 08:35:26 EST
This needed more work so the commit that implements this feature in full is:

commit 689adfded272d5021c61a05e67acd87b0717205a
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Thu Nov 18 14:16:50 2010 +0100

    BZ 568917 - Implementing ContentFacet on ScriptComponent so that the support for uploading a new script is complete.
Comment 6 Rajan Timaniya 2010-11-25 05:15:06 EST
Verified on JON 2.4.1 Revision: 10957 (build #28)

Observation:
There is check box next to child resources of type "Script" (uninventory is also working fine) and also on inventory tab of the JBossAS server script has check box and can be deleted.
Comment 8 Heiko W. Rupp 2013-08-31 07:05:17 EDT
This has been verified long time ago.

Note You need to log in before you can comment on or make changes to this bug.