This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 534866 - (RHQ-1620) apache discovery found a ghost apache
apache discovery found a ghost apache
Status: CLOSED DUPLICATE of bug 698474
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
1.2
All All
high Severity low (vote)
: ---
: ---
Assigned To: Lukas Krejci
http://jira.rhq-project.org/browse/RH...
:
: 563705 (view as bug list)
Depends On:
Blocks: jon24-apache jon30-bugs
  Show dependency treegraph
 
Reported: 2009-02-20 15:02 EST by John Mazzitelli
Modified: 2011-11-16 13:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-16 13:32:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2009-02-20 15:02:00 EST
I have apache installed and running out of  C:\mazz\apache-httpd. I do NOT have C:\apache or anything under C:\ that resembles apache.

The apache discovery is discovering my apache server plus another one - but its a ghost - doesn't really exist on my box:

sending> discovery -r "Apache HTTP Server"
Apache.Apache HTTP Server: Starting discovery...
Apache.Apache HTTP Server: Process scan detected a server - scan=[ProcessScan: query=[process|basename|match=httpd.*,process|basename|nomatch|parent=httpd.*], name=[HttpdOnUnix]], process=[process: pid=[508], name=[C:\mazz\apache-httpd\bin\httpd.exe], ppid=[1880]]
Apache.Apache HTTP Server: Process scan detected a server - scan=[ProcessScan: query=[process|basename|match=(?i)httpd.exe,process|basename|match|parent=(?i)httpd.exe], name=[HttpdOnWindows]], process=[process: pid=[624], name=[C:\mazz\apache-httpd\bin\httpd.exe], ppid=[508]]
Apache.Apache HTTP Server: key=[C:\mazz\apache-httpd], name=[mazzthink Apache 2.2.9 (C:\mazz\apache-httpd\)], version=[2.2.9], description=[Apache Web Server]
Apache.Apache HTTP Server: key=[C:\apache], name=[mazzthink Apache 2.2.9 (C:\apache\)], version=[2.2.9], description=[Apache Web Server]
Apache.Apache HTTP Server: Done.
Comment 1 John Mazzitelli 2009-02-20 15:05:36 EST
Here's the results of those piql queries:

shutdown> piql verbose process|basename|match=httpd.*,process|basename|nomatch|parent=httpd.*
PIQL Query: [process|basename|match=httpd.*,process|basename|nomatch|parent=httpd.*]
Found the following matching processes:
pid=508, ppid=1880, name=C:\mazz\apache-httpd\bin\httpd.exe, created=2/20/09, kernel-time=15, user-time=62, command-line=[C:\mazz\apache-httpd\bin\httpd.exe, -k, runservice]

shutdown> piql verbose process|basename|match=(?i)httpd.exe,process|basename|match|parent=(?i)httpd.exe
PIQL Query: [process|basename|match=(?i)httpd.exe,process|basename|match|parent=(?i)httpd.exe]
Found the following matching processes:
pid=624, ppid=508, name=C:\mazz\apache-httpd\bin\httpd.exe, created=2/20/09, kernel-time=31, user-time=31, command-line=[C:\mazz\apache-httpd\bin\httpd.exe, -d, C:/mazz/apache-httpd, -f, C:\mazz\apache-httpd\conf\httpd.conf, -d, C:\mazz\apache-httpd\.]
Comment 2 Heiko W. Rupp 2009-03-04 15:15:26 EST
I was trying to reproduce this on XP and did not see errors:

Can you try again locally? Probably by first uninventoring existing apaches?



> discovery
Apache.Apache HTTP Server: Starting discovery...
Apache.Apache HTTP Server: Process scan detected a server - scan=[ProcessScan:
query=[process|basename|match=(?i)httpd.exe,process|basename|match|parent=(?i)httpd.exe], name=[HttpdOnWindows]], process=[process: pid=[3912], name=[C:\heiko\apache-httpd\bin\httpd.exe], ppid=[3876]]
Apache.Apache HTTP Server: Process scan detected a server - scan=[ProcessScan:
query=[process|basename|match=httpd.*,process|basename|nomatch|parent=httpd.*],
name=[HttpdOnUnix]], process=[process: pid=[3876], name=[C:\heiko\apache-httpd\bin\httpd.exe], ppid=[1972]]
Apache.Apache HTTP Server: key=[C:\heiko\apache-httpd], name=[bender Apache 2.2
.11 (C:\heiko\apache-httpd\)], version=[2.2.11], description=[Apache Web Server]
Apache.Apache HTTP Server: Done.


> piql verbose process|basename|match=httpd.*,process|basename|nomatch|parent=httpd.*
PIQL Query: [process|basename|match=httpd.*,process|basename|nomatch|parent=httpd.*]
Found the following matching processes:

pid=3876, ppid=1972, name=C:\heiko\apache-httpd\bin\httpd.exe, created=04.03.09
 kernel-time=120, user-time=30, command-line=[C:\heiko\apache-httpd\bin\httpd.exe, -w, -f, C:\heiko\apache-httpd\conf\httpd.conf, -d, C:\heiko\apache-httpd\.]
>


> piql verbose process|basename|match=(?i)httpd.exe,process|basename|match|parent=(?i)httpd.exe
PIQL Query: [process|basename|match=(?i)httpd.exe,process|basename|match|parent=(?i)httpd.exe]
Found the following matching processes:

pid=3912, ppid=3876, name=C:\heiko\apache-httpd\bin\httpd.exe, created=04.03.09,
 kernel-time=80, user-time=40, command-line=[C:\heiko\apache-httpd\bin\httpd.exe
, -d, C:/heiko/apache-httpd, -f, C:\heiko\apache-httpd\conf\httpd.conf, -d, C:\heiko\apache-httpd\.]
>
Comment 3 Red Hat Bugzilla 2009-11-10 15:36:53 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1620
This bug is duplicated by RHQ-1942
Comment 4 Filip Drabek 2010-04-22 06:58:10 EDT
*** Bug 563705 has been marked as a duplicate of this bug. ***
Comment 5 Heiko W. Rupp 2010-04-22 08:59:04 EDT
After having a quick look at the code again - I think we could "harden" the code by actually looking at the file found if this really exists and if it is executable and if it is on Win* even if it really a .exe
If the binary does not exist at the path or is not executable, we ignore it.
Comment 6 Charles Crouch 2010-04-23 14:18:44 EDT
Lower priority on this, if time it should be done as part of the other apache work.
Comment 7 Charles Crouch 2011-06-08 15:43:52 EDT
Raising priority and assigning to Lukas as he is currently working in this area. This may just need testing and pushing to QE
Comment 8 Lukas Krejci 2011-11-16 05:14:18 EST
I believe bug 698474 might have fixed this.
Comment 9 Mike Foley 2011-11-16 13:32:13 EST

*** This bug has been marked as a duplicate of bug 698474 ***

Note You need to log in before you can comment on or make changes to this bug.