This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 563705 - Apache plugin detects non-existent httpd instance on Windows
Apache plugin detects non-existent httpd instance on Windows
Status: CLOSED DUPLICATE of bug 534866
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
1.3
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
: SubBug
Depends On:
Blocks: rhq_triage jon24-apache
  Show dependency treegraph
 
Reported: 2010-02-10 17:08 EST by Ondřej Žižka
Modified: 2010-04-22 14:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-22 06:58:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ondřej Žižka 2010-02-10 17:08:08 EST
Versions:
=========

JON 2.3.0.GA
Windows 2003 x32

Steps to Reproduce:
===================

I've installed JON agent on Windows, and it discovered a HTTPD instance which does not exist:
 - The reported directory does not exist - c:\apache
 - This path is nowhere in registry
 - No such service exists
 - Neither have I found it in agent config XML

So I wonder where did it get this instance from. Does it come from some defaults?

Agent's `avail` reports it as: DOWN:   JAWA14 Apache 2.2.10 (C:\apache\)
In JON, it is also reported as down, with this message (stack trace attached):

Failed to start component for resource Resource[id=10242, type=Apache HTTP Server, key=C:\work\EWS\Enterprise Web Server, name=JAWA14 Apache 2.2.14 (C:\work\EWS\Enterprise Web Server\), parent=jawa14, version=2.2.14].
Comment 1 Ondřej Žižka 2010-02-10 17:12:48 EST
Now when I clicked on connection properties, I see that 

"Executable Path" == C:\Program Files (x86)\Apache Software Foundation\Apache2.2\bin\httpd.exe

"Server Root" == C:\apache

However, this directory also does not contain "C:\apache" in any config file.
Comment 2 Ondřej Žižka 2010-02-10 17:18:12 EST
For anyone willing to check, it's on jawa14 (ask someone from JBoss QA for the password):

LANG=en rdesktop -u Administrator jawa14.englab.brq.redhat.com
Comment 3 wes hayutin 2010-02-16 11:52:07 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 4 wes hayutin 2010-02-16 11:58:05 EST
making sure we're not missing any bugs in rhq_triage
Comment 5 Filip Drabek 2010-04-22 06:58:10 EDT

*** This bug has been marked as a duplicate of bug 534866 ***

Note You need to log in before you can comment on or make changes to this bug.