Bug 53576 - file does not work for files over 2GB in size
Summary: file does not work for files over 2GB in size
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: file (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 71850 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-12 08:19 UTC by Tom Hughes
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-06 21:42:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom Hughes 2001-09-12 08:19:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (X11; I; UNIX_SV 4.2MP i386; Nav)

Description of problem:
using file with a file over 2GB results in the error message:
file cyber
cyber: can't stat `cyber' (Value too large for defined data type).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a filew over 2GB in size
2. Run "file <filename>".
3.
	

Actual Results:  cyber: can't stat `cyber' (Value too large for defined
data type).

Expected Results:  It tells me it's a tar file (or whatever it is).

Additional info:

Comment 1 Trond Eivind Glomsrxd 2001-12-11 20:06:47 UTC
Fixed in file-3.37-2

Comment 2 Trond Eivind Glomsrxd 2002-08-20 16:01:58 UTC
*** Bug 71850 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.