Bug 535772 - (RHQ-2433) Internet Explorer (IE) problem with Advanced Settings
Internet Explorer (IE) problem with Advanced Settings
Status: CLOSED WORKSFORME
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
3.0.0
All All
low Severity medium (vote)
: ---
: ---
Assigned To: Filip Drabek
http://jira.rhq-project.org/browse/RH...
: Reopened, SubBug
: 574769 (view as bug list)
Depends On:
Blocks: jon241-bugs
  Show dependency treegraph
 
Reported: 2009-09-16 16:44 EDT by dsteigne
Modified: 2013-08-31 07:04 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Internet Explorer version 7.0 Also confirmed on IE8
Last Closed: 2013-08-31 07:04:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dsteigne 2009-09-16 16:44:00 EDT
On the monitoring tab of a resource when a user clicks on "Advanced Settings " link to change the time interval to view the displayed metrics, nothing happens.  Pop-up blocker is disabled.
Issue Tracker ticket # 343060
Comment 1 Jeff Weiss 2009-09-16 16:54:57 EDT
Also fails in rev5152 on IE8
Comment 2 Jay Shaughnessy 2009-09-16 17:05:14 EDT
WORKAROUND:

Click on the metric in the chart.  At the bottom of the screen is the Advanced Settings (Display Range Settings).  It is working from this location.
Comment 3 Red Hat Bugzilla 2009-11-10 16:04:22 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2433
Comment 4 wes hayutin 2010-02-16 11:56:39 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 5 wes hayutin 2010-02-16 12:01:49 EST
making sure we're not missing any bugs in rhq_triage
Comment 6 Corey Welton 2010-10-06 23:43:28 EDT
closing per gwt effort
Comment 7 Larry O'Leary 2010-10-19 18:36:37 EDT
This issue seems to keep getting reported/hit by customers. With such a simple fix, it might be worth getting the fix committed in lieu of the GWT effort in RHQ 4 and the workaround proposed in Comment 2.

The 'onclick' event for the "Advanced Settings..." link is calling the JavaScript window.open() method with an invalid 'strWindowName' parameter.

<a href="#" onclick="javascript:window.open('/rhq/common/metric/advanced.xhtml','Metric Display Range Settings','width=450,height=375');">Advanced Settings...</a>

Although spaces in the window name value are tolerated in many web browsers, some browsers will fail to execute the window.open() method due to the value of "Metric Display Range Settings".

The window name value must be a valid identifier and therefore can not contain spaces in its name:
See: https://developer.mozilla.org/en/DOM/window.open

I performed a quick search of the code and it appears that this is the only place that such a thing has occurred.


diff --git a/modules/enterprise/gui/portal-war/src/main/java/org/rhq/enterprise/gui/common/metric/MetricRenderer.java b/modules/enterprise/gui/portal-war/src/main/java/org/rhq/enterprise/gui/common/metric/MetricRenderer.java
index 0018101..d4a44e1 100644
--- a/modules/enterprise/gui/portal-war/src/main/java/org/rhq/enterprise/gui/common/metric/MetricRenderer.java
+++ b/modules/enterprise/gui/portal-war/src/main/java/org/rhq/enterprise/gui/common/metric/MetricRenderer.java
@@ -129,7 +129,7 @@ public class MetricRenderer extends Renderer {
         writer.startElement("a", null);
         writer.writeAttribute("href", "#", null);
         writer.writeAttribute("onclick",
-            "javascript:window.open('/rhq/common/metric/advanced.xhtml','Metric Display Range Settings','"
+            "javascript:window.open('/rhq/common/metric/advanced.xhtml','MetricDisplayRangeSettings','"
                 + getWindowOptions() + "');", null);
         if (rangePreferences.readOnly) {
             writer.write("Edit Settings...");
Comment 9 Charles Crouch 2010-11-01 20:48:11 EDT
*** Bug 574769 has been marked as a duplicate of this bug. ***
Comment 10 Filip Drabek 2010-12-09 10:09:20 EST
commit 6b251b7c1d4c7f8f32ea49df17732d72ab06adde release-3 branch
Comment 11 Rajan Timaniya 2010-12-10 07:21:04 EST
Tested in JON 2.4.1

Browser IE-7/8

"Advanced Settings" links of monitoring tab of a resource shows pop-up to change the time interval and it works fine.
Comment 12 Heiko W. Rupp 2013-08-31 07:04:17 EDT
Has been verified loong time ago

Note You need to log in before you can comment on or make changes to this bug.