Bug 53607 - Sendmail 8.11.6 not acceptiong remote connections
Sendmail 8.11.6 not acceptiong remote connections
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
: 54143 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-12 15:34 EDT by Christopher Martinsen
Modified: 2007-04-18 12:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-23 20:32:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Martinsen 2001-09-12 15:34:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9 i686)

Description of problem:
On 09-10-01 I installed the security update which redhat released for
sendmail. I upgraded two RH6.2 systems from sendmail-8.9.3-20 to
sendmail-8.11.6-1.6.x.i386.rpm. After the upgrade. I tried to restart and
sendmail told me that it couldn't find the sendmail.cw file. I checked the
sendmail.cf.rpmnew file and saw that that information had moved to
/etc/mail/local-host-names. This was referenced in the new sendmail.cf
file. So I copied the sendmail.cf.rpmnew over sendmail.cf, luckily
preserving a copy. I restarted sendmail and everything seemed to be good.
These machines are web servers so most of the email is outgoing as opposed
to incoming.

Today, 09-12-01, I recieved a report that one of the mail aliases wasn't
working. I took a look as saw that my internal mail server was not able to
connect to the machine. I tried to telnet to the IP address and port 25.
The connection was refused. Which means the mail server was not accepting
external connections. I thought that was what sendmail.cw handled.

Finally I wound up reverting back to the version that had worked well
before because I was not really able to figure out how to make sendmail
accept the external connections that I needed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  install sendmail-8.11.6
2. copy over sendmail.cf.rpmnew to sendmail.cf, restart sendmail
3. try to connect to mail server using telnet hostname port 25
	

Additional info:
Comment 1 Need Real Name 2001-09-16 14:57:20 EDT
I have exactly the same problem.
Sendmail refuses to listen on anything but localhost.
It won't accept connections from outside.
Even adding the hostname+domain in /etc/mail/local-host-names
does not help: sendmail *only* listens on 127.0.0.*  !
There is nothing special about my setup so I think there
must be many people experiencing the same problem.

    greetings,
    Rob van Nieuwkerk
Comment 2 steve 2001-09-21 18:09:03 EDT
I too have had this problem.  Sendmail made no complaints upon starting up, but
refused all outside connections on port 25.  I'm running RedHat 6.2, and still
running kernel 2.2.14-5.0.  Everything else is upgraded to the latest 
versions.  My only solution to this has been downgrading to the previous 
version.
Comment 3 Need Real Name 2001-09-21 18:18:44 EDT
I found the cause of the problem.

Starting with RH 7 sendmail does not listen to anything but

localhost by default.  Apparently Red Hat just recompiled the

current sendmail SRPM also for the security fix that was made

for Red Hat 6.2. The sendmail that originally came with RH 6.2

does *not* have this default, so this can be very confusing to

6.2 users who applied this security update !! (RH are you listening?)


On http://www.redhat.com/support/resources/gotchas/7.1/gotchas-71.html

under the section "Sendmail Will Not Accept Outside Connections

After Installation" you can find the solution to the problem !

    greetings,
    Rob van Nieuwkerk
Comment 4 Alec Voropay 2001-09-28 08:47:32 EDT
*** Bug 54143 has been marked as a duplicate of this bug. ***
Comment 5 Steven Roberts 2001-10-23 20:32:13 EDT
Nailed us too.  (really would have been nice if the errate for the sendmail update warned about this.

For the short answer change this:
O DaemonPortOptions=Port=smtp,Addr=127.0.0.1, Name=MTA
to 
O DaemonPortOptions=Port=smtp,Addr=0.0.0.0, Name=MTA

in /etc/sendmail.cf (the 8.9.3 install had it commented out, guessing that works as well)
Comment 6 Florian La Roche 2001-12-08 04:52:17 EST
Updated rpms leave network connections open for older Red Hat Linux
releases and only change this for newer products.

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.