Bug 536144 - (RHQ-526) leverage latched concurrent framework to deploy plugins concurrently during server startup
leverage latched concurrent framework to deploy plugins concurrently during s...
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Performance (Show other bugs)
1.0
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On: RHQ-525
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 12:36 EDT by Joseph Marques
Modified: 2009-11-10 16:22 EST (History)
0 users

See Also:
Fixed In Version: 1.0.1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2008-05-29 12:36:00 EDT
the benefit might be small now, but with a serialized startup process this will only get worse in the future.  think of what the server startup times would be if a user has 50 deployed plugins.  this will significantly reduce the time needed to start all plugins, because the plugin deployer will be able to deploy concurrently those that are not part of the same lineage.  furthermore, once a common ancestor is successfully deploy, all descendant lineages will proceed with their deploys concurrently.
Comment 1 Joseph Marques 2008-05-29 12:38:55 EDT
rev884 - subclassed LatchService to capture the required pieces of information needed during a plugin deployment; 
rewrote main part of plugin deployer to leverage the latched concurrent controller framework to concurrently deploy plugins; 
Comment 2 Joseph Marques 2008-05-29 15:32:11 EDT
rev885 - fixed typo for logger initialization
rev887 - typo, the completion latch should have also been final
Comment 3 Joseph Marques 2008-06-12 13:18:13 EDT
closing this code-level item, no qa necessary.
Comment 4 Red Hat Bugzilla 2009-11-10 16:11:08 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-526

Note You need to log in before you can comment on or make changes to this bug.