Bug 53652 - missing setuid bit on /usr/sbin/traceroute6
missing setuid bit on /usr/sbin/traceroute6
Status: CLOSED DUPLICATE of bug 23792
Product: Red Hat Linux
Classification: Retired
Component: iputils (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2001-09-13 20:28 EDT by Matt Selsky
Modified: 2015-03-04 20:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-09-13 20:45:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matt Selsky 2001-09-13 20:28:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9 i686; Nav)

Description of problem:
I compiled a 2.4.9 kernel with ipv6 support and when I try to do a
traceroute6 to it as a regular user I get an error message that the socket
operation is not permitted.  If I become root and try the same thing, it
works.  /usr/sbin/traceroute is setuid root, to enable it to perform raw
socket operations.  It seems that /usr/sbin/traceroute6 needs to be setuid
root as well.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

[selsky@ice selsky]$ /usr/sbin/traceroute6 ftp.netbsd.org

Actual Results:  traceroute6: icmp socket: Operation not permitted

Expected Results:

[root@ice /root]# /usr/sbin/traceroute6 ftp.netbsd.org
traceroute to ftp.netbsd.org (3ffe:8050:201:1860:2a0:c9ff:feed:b7ea) from
700:904:119:200:86ff:fe18:fe3d, 30 hops max, 16 byte packets
 1  3ffe:3700:904:119:260:3eff:fe3f:1a20
 15.078 ms *  1.154 ms
 2  nnsyr-columbia-v6.nyser.net (3ffe:3700:93f:104::1)  16.952 ms *  13.346
 3  3ffe:3700:ff:249::1 (3ffe:3700:ff:249::1)  28.826 ms  28.893 ms  28.45
 4  dnvr-clev.ipv6.abilene.ucaid.edu (3ffe:3700:ff:203::2)  59.52 ms 
59.387 ms 
 59.101 ms
 5  3ffe:3700:ff:5c1::2 (3ffe:3700:ff:5c1::2)  94.514 ms  94.887 ms  94.76
 6  3ffe:800::fff9:0:0:2 (3ffe:800::fff9:0:0:2)  113.107 ms  117.182 ms 
112.206 ms
 7  orrc3.unnwo.net (3ffe:8050:ffff:ffff::f)  112.561 ms  112.295 ms 
113.68 ms
 8  ftp6.netbsd.org (3ffe:8050:201:1860:2a0:c9ff:feed:b7ea)  113.997 ms 
112.086 ms  112.789 ms
Comment 1 Matt Selsky 2001-09-13 20:52:34 EDT

*** This bug has been marked as a duplicate of 23792 ***

Note You need to log in before you can comment on or make changes to this bug.