Bug 53664 - RFE: Can't force disk partition to be non-primary
Summary: RFE: Can't force disk partition to be non-primary
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
: 56694 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-14 11:02 UTC by Alexandre Oliva
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2001-09-14 11:02:12 UTC
It would be nice to be able to force a partition to be a logical one,
instead of a primary one.  Sometimes I want to leave a primary partition
free to install FreeDOS or a save2disk partition, but Disk Druid will
create all partitions as primary unless the maximum number of partitions is
exceeded, so I have to use fdisk or parted to allocate the partitions, then
use diskdruid to assign them mountpoints.

Comment 1 Brent Fox 2001-09-14 15:27:23 UTC
We changed this because people complained in the past that we made an extended
partition before it was absolutely necessary.  Now we're hearing that we make
the extended partition too late.  There's a balance we have to make between
building a general purpose partitioning tool that is easy to use, but lacks all
the possible options, and building an all-purpose tool that is very complicated
to use.

In general, Disk Druid is designed to make partitioning possible for the user
that doesn't necessarily understand partitioning.  The reason that fdisk is
included in the install is for the kind of customized setup that you need.  

katzj, I don't know if you want to implement this or not, but I'm leaning
towards keeping Disk Druid as simple as possible.  Maybe we could do this for
kickstart installs.

Comment 2 Jeremy Katz 2001-09-14 16:17:39 UTC
The question of primary vs logical and making a partition be what you want will
be revisited in the future.

Comment 3 Jeremy Katz 2002-03-18 17:24:54 UTC
*** Bug 56694 has been marked as a duplicate of this bug. ***

Comment 4 Michael Fulbright 2002-03-26 17:43:48 UTC
Deferring to future release.

Comment 5 Red Hat Bugzilla 2006-02-21 18:48:08 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.