Bug 56694 - A way to force a partition to be "extended" apparently missing in Disk Druid
A way to force a partition to be "extended" apparently missing in Disk Druid
Status: CLOSED DUPLICATE of bug 53664
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
: 48086 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2001-11-25 00:56 EST by Michal Jaegermann
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-02-21 11:57:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-11-25 00:56:40 EST
Description of Problem:

Current version of Disk Druid has a way to force a given partition to
be "primary" (thank you!) but it does not appear to be a way to declare
that one wants that partition to _really_ be "extended" (or "logical")
other than "going over a limit" with primary partitions.  There are
situations when this is truly desirable.  I know that there are
ways to get around that but they can get quite convoluted (when
working with a prospective RAID array, for example).
Comment 1 Jeremy Katz 2001-11-28 16:58:06 EST
*** Bug 48086 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2001-11-28 17:10:51 EST
Yep, slated to be fixed for the next release
Comment 3 Michael Fulbright 2002-01-16 15:19:57 EST
I'm not clear what behavior you are asking for. Are you saying you would like a
way to specify that a partition should go inside an extended partition as a
logical? What if there are no partitions on the drive - are you wanting it to
make an extended partition which is the entire disk?  Making a partition
'primary' is easy to interpret, I'm not sure its so clear with logical partitions.
Comment 4 Michal Jaegermann 2002-01-17 11:41:32 EST
A request is for an ability to declare any of basic kinds of a partition
from a FAT-type partition table.  Right now I can, at least and at last,
to ask for a specific partition to be primary (within obvious limitations,
of course) but if I create the next one Disk Druid may decide for me to
make it either primary, extended or logical - without an apparent rhyme or
reason, and there are situations where it is crucial to control that.

I know that I can back off to fdisk, write partitions there, go back again,
and switch do Disk Druid to write for me raid tables (which is PITA to do
by hand especially if there is a bigger number of spindles around and has
to be really done through Disk Druid if one insists on doing that while
installing) but adding an option for a user to be control kinds, if a need
will arise, should not be complicated.
Comment 5 Jeremy Katz 2002-03-18 12:25:00 EST

*** This bug has been marked as a duplicate of 53664 ***

Note You need to log in before you can comment on or make changes to this bug.