Bug 53691 - anaconda starts in textmode on a by X supported system and freezes after formating partitions
anaconda starts in textmode on a by X supported system and freezes after form...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 53690 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-15 06:24 EDT by Marc Richter
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-19 05:37:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Richter 2001-09-15 06:24:39 EDT
Description of Problem:

When booting from the first CD anaconda starts without error message on 
console 3 or 4 into textmode.
The second problem is that it freezes after formating the partitions.

How Reproducible:

It occours everytime on my systems hardware configuration

Steps to Reproduce:

Simply try to install RedHat Linux on a Machine matching my configuration.

Actual Results:

Linux is not installable

Expected Results:

Linux should be installable, shouldn't it? ;)

Additional Information:
	
RedHat 7.0 was once installable on the same machine it now fails. The only 
three things that could have changed since the are:
1. My partitions
2. Added a second HDD
3. Updated my BIOS to version F8

My Hardware: HDD1: 16.473MB Maxtore, HDD2: 39.087MB Fujitsu, Graphic card: 
3dfx VoodooIII 3000 AGP, RAM: 128MB (2x 64MB), Motherboard: Gigabyte GA-
7IXE4, Processor: AMD Duron 800

My Partitions: HDD1:
[active; primary; 7,8MB; ext2fs; /boot], [-; primary; 6.000,8MB; FAT32; -
], [-; logical; 6.957,8MB; ext2fs; /], [-; logical; 3.506,3MB; FAT32; -]

HDD2:
[-; primary; 20.002,8MB; FAT32; -], [-; logical; 18.583,0MB; FAT32; -], [-
; logical; 502,0MB; SWAP; SWAP]
Comment 1 Matt Wilson 2001-09-16 23:35:49 EDT
*** Bug 53690 has been marked as a duplicate of this bug. ***
Comment 2 Brent Fox 2001-09-17 10:51:00 EDT
When in the installer, try going to F2 and typing 'cat /proc/meminfo' and post
the results of that here.  I think the kernel may not be seeing all of your RAM.
Comment 3 Marc Richter 2001-09-17 16:51:39 EDT
The shown results are:

           total:     used:      free:     shared:    buffers:   cached:
mem:      14688256   14295040    393216    2142208     4116480   3354624
Swap:            0          0         0
MemTotal:          14344 kB
MemFree:             384 kB
MemShared:          2092 kB
Buffers:            4020 kB
Cached:             3276 kB
BigTotal:              0 kB
BigFree:               0 kB
SwapTotal:             0 kB
SwapFree:              0 kB

=============================================================================

I hope it helps to fix that problem...
Comment 4 Brent Fox 2001-09-18 11:57:14 EDT
I was right.  The kernel is only seeing 14MB of RAM in your system.  I can only
assume that the upgrade to the BIOS caused this problem.  The install will force
text mode if there's less than 35MB of RAM.  Since the kernel is only seeing
14MB, that's what is happening.  Try booting with 'linux mem=128M"  That should
force the kernel to see all 128MB of your RAM.  Does that help?
Comment 5 Marc Richter 2001-09-19 05:37:39 EDT
... wow, it works! :) Thank you!
Comment 6 Brent Fox 2001-09-19 10:42:18 EDT
I guess the motherboard maker messed up when they released the BIOS update since
it used to work.  Weird.  Anyway, glad to know things are working now.  Thanks
for your report.

Note You need to log in before you can comment on or make changes to this bug.