This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 537067 - Not probably to spend network installation fedora 12 (beta) from a NFS-server
Not probably to spend network installation fedora 12 (beta) from a NFS-server
Status: CLOSED DUPLICATE of bug 528537
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-12 06:28 EST by Alex
Modified: 2009-11-12 14:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-12 14:23:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
photo-2 (372.65 KB, image/jpeg)
2009-11-12 06:30 EST, Alex
no flags Details
photo-3 (269.68 KB, image/jpeg)
2009-11-12 06:31 EST, Alex
no flags Details
photo-4 (344.83 KB, image/jpeg)
2009-11-12 06:32 EST, Alex
no flags Details
photo-5 (248.23 KB, image/jpeg)
2009-11-12 06:33 EST, Alex
no flags Details
photo-6 (248.44 KB, image/jpeg)
2009-11-12 06:34 EST, Alex
no flags Details
photo-7 (221.94 KB, image/jpeg)
2009-11-12 06:35 EST, Alex
no flags Details
photo-8 (530.68 KB, image/jpeg)
2009-11-12 06:36 EST, Alex
no flags Details
photo-9 (567.18 KB, image/jpeg)
2009-11-12 06:37 EST, Alex
no flags Details
photo-1 (547.69 KB, image/jpeg)
2009-11-12 06:39 EST, Alex
no flags Details

  None (edit)
Description Alex 2009-11-12 06:28:12 EST
Description of problem:
At network installation fedora 12 (beta) on the computer using PXE it is impossible to spend installation from a NFS-server. The network resource is not mounted. Besides, at network installation not probably to set Russian though earlier (fedora 8,9,10,11) it could be made.
Nevertheless it is possible to spend installation with web-server usage.

Version-Release number of selected component (if applicable):
1. Install DVD Fedora 12 (beta) for reception initrd.img, vmlinuz (from a
directory .../images/pxeboot)
2. syslinux-3.75-4.fc12.i686.rpm (Fedora Development for i386) for reception
pxelinux.0

How reproducible:


Steps to Reproduce:
1. Begin network installation fedora 12 (beta) (see photo-1.JPG)
2. Select for installation Russian (see photo-2.JPG). There is an error (see photo-3.JPG). Why?
3. Select NFS directory (see photo-4.JPG). Select "Manual configuration" from customisations TCP/IP (see photo-5.JPG).
4. After definition of network customisations enter parametres of a NFS-server (192.168.1.254) and a shared directory /var/www/html/linux/f12/i386/install (see photo-6.JPG). Press "Ok"
5. Error! The network resource is not mounted (see photo-7.JPG).
6. Switch Alt-F4 (see net-8.JPG)
7. Switch Alt-F3 (see net-9.JPG)
  
Actual results:
No install

Expected results:


Additional info:
DCHP-,TFTP anf NFS-servers work on computer:
1) OS - Fedora 7
2) Files for loading are on the patch:
/tftpboot/linux/f12/i386
3) List files:
initrd.img  pxelinux.0  vmlinuz
4) List /tftpboot/linux/f12/i386/pxelinux.cfg:
default
5) cat /tftpboot/linux/f12/i386/pxelinux.cfg/default
DEFAULT pxeboot
TIMEOUT 50
LABEL pxeboot
      KERNEL vmlinuz
      APPEND initrd=initrd.img
ONERROR LOCALBOOT 0

6) exportfs
....
/var/www/html/linux/f12/i386/install
                192.168.1.0/24
....
/var/www/html/linux/f12/i386/install
                <world>
....
Comment 1 Alex 2009-11-12 06:30:00 EST
Created attachment 369185 [details]
photo-2
Comment 2 Alex 2009-11-12 06:31:51 EST
Created attachment 369188 [details]
photo-3
Comment 3 Alex 2009-11-12 06:32:34 EST
Created attachment 369189 [details]
photo-4
Comment 4 Alex 2009-11-12 06:33:36 EST
Created attachment 369190 [details]
photo-5
Comment 5 Alex 2009-11-12 06:34:24 EST
Created attachment 369191 [details]
photo-6
Comment 6 Alex 2009-11-12 06:35:52 EST
Created attachment 369192 [details]
photo-7
Comment 7 Alex 2009-11-12 06:36:55 EST
Created attachment 369193 [details]
photo-8
Comment 8 Alex 2009-11-12 06:37:59 EST
Created attachment 369194 [details]
photo-9
Comment 9 Alex 2009-11-12 06:39:33 EST
Created attachment 369195 [details]
photo-1
Comment 10 Radek Vykydal 2009-11-12 08:49:36 EST
This looks like duplicate of bug #528537 that should be fixed post-beta. Could you please try if this workaround: https://bugzilla.redhat.com/show_bug.cgi?id=528537#c4 on the NFS server side works for you?
Comment 11 Alex 2009-11-12 14:08:09 EST
yes,

1) on the NFS-server, add string RPCNFSDARGS="-N 4" in file /etc/sysconfig/nfs

2) reboot NFS-server

3) Has booted successfully, but as a result there is a same error as well as in Bug 537175
Comment 12 Chris Lumens 2009-11-12 14:23:07 EST

*** This bug has been marked as a duplicate of bug 528537 ***

Note You need to log in before you can comment on or make changes to this bug.