Bug 528537 - fails to get kickstart file over nfs.
fails to get kickstart file over nfs.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 526494 527257 528653 529462 537067 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-12 13:22 EDT by Dave Jones
Modified: 2015-01-04 17:31 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-02 17:19:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed Patch (815 bytes, text/plain)
2009-10-13 16:14 EDT, Steve Dickson
no flags Details

  None (edit)
Description Dave Jones 2009-10-12 13:22:58 EDT
my tftp config passes this to the boot command line ..

ks=nfs:192.168.42.10:/mnt/data/mirror/kick/nwo.ks

this has worked before. The IP is correct, and the file is still there.

When it gets to the part where it is supposed to retrieve the file, it gives me the 'Error downloading kickstart file' dialog.

on tty3, I see ..

getting kickstart file
only have one network device: eth0
doing kickstart... setting it up
get_connection (2132) NetworkManager connected
url is 192.169.42.10:/mnt/data/mirror/kick/nwo.ks
file location: nfs:192.168.42.10:/mnt/data/mirror/kick/nwo.ks
failed to mount nfs source

on tty4, I see it has loaded the nfs kernel module, and then 

rpcbind: server localhost not responding, timed out.


Could this have something to do with the nfs-utils changes Steve pushed to rawhide recently ?

Server is an F11 box running all the latest updates.

The export is ..
/mnt/data	*(rw,sync)
Comment 1 Steve Dickson 2009-10-12 15:12:53 EDT
what nfs-utils version are you using??
Comment 2 Dave Jones 2009-10-12 15:16:31 EDT
client: 1.2.0-16.fc12
server: 1.2.0-5.fc11
Comment 3 Chris Lumens 2009-10-13 09:07:17 EDT
*** Bug 528653 has been marked as a duplicate of this bug. ***
Comment 4 Dave Jones 2009-10-13 11:37:55 EDT
for the benefit of others:

debugged this in irc with steve yesterday. This is happening because nfs-utils tries an nfsv4 mount, which fails, and it isn't falling back to an nfsv3/v2 mount.

workaround:
on the server, edit /etc/sysconfig/nfs, and uncomment the line that reads

RPCNFSDARGS="-N 4"

restart the nfs service, and it should work.
Comment 5 Chris Lumens 2009-10-13 13:34:47 EDT
*** Bug 527257 has been marked as a duplicate of this bug. ***
Comment 6 James Laska 2009-10-13 15:20:18 EDT
Adding CommonBugs keyword
Comment 7 Steve Dickson 2009-10-13 16:14:14 EDT
Created attachment 364646 [details]
Proposed Patch

I've just proposed this upstream and will keep you updated
on its progress... but I would suggest we think incorporating this
one line fix sooner verses later since it does indeed stop the
client from hanging when rpcbind is not running (like with all 
nfs installs).
Comment 8 Steve Dickson 2009-10-13 18:36:53 EDT
Book it Danno! The patch just got the thumbs up from the maintainer... 

http://linux-nfs.org/pipermail/nfsv4/2009-October/011420.html
Comment 9 Stijn Hoop 2009-10-14 06:35:04 EDT
Running into this bug. Setting the mount option on the live server is going to be ... tricky. Any other workaround or will I have to wait for the fix (which I presume is going to go into rawhide kernel before F12 GA ?)
Comment 10 Michal Jaegermann 2009-10-21 19:54:35 EDT
> workaround:
... from comment #4.

Indeed it worksforme but these are current rawhide images with anaconda 11.38
and this workaround is still required.

Before I stumbled into this one I found bug 529462 (is this is a duplicate?) and added https://bugzilla.redhat.com/show_bug.cgi?id=529462#c6 and
https://bugzilla.redhat.com/show_bug.cgi?id=529462#c7 there.  That describes what I can collect on different screens.  What shows up is not that helpful, I am afraid.

I wonder what else will go haywire instead.  A server used in these experiments provides installation over PXE for various distros.  Just yesterday I was using it for CentOS 5.4 installation and no edits in /etc/sysconfig/nfs were needed.
Comment 11 Adam Williamson 2009-10-21 20:17:34 EDT
michal: i believe it's expected still to be broken, as the patch hasn't gone into current rawhide yet.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Stijn Hoop 2009-10-22 09:25:26 EDT
Michal: I see exactly the same messages as you described in bug 529462 comment 6.

Because I can't easily edit the NFS options on the live server, another workaround I found is to patch anaconda to honor NFS options, for progress on that see bug 529197. Note that I haven't yet done a successfull install using that patch but it at least avoids the loader waiting for an unsuccesfull NFSv4 mount.
Comment 13 Steve Dickson 2009-10-23 08:58:43 EDT
*** Bug 526494 has been marked as a duplicate of this bug. ***
Comment 14 Adam Williamson 2009-10-23 14:48:29 EDT
Looks like this went into a Koji kernel already:

* Tue Oct 13 2009 Steve Dickson <steved@redhat.com> 2.6.31.4-81 - Fixed hang during NFS installs (bz 528537) 

but we haven't had a kernel build tagged in for a while, rawhide is still on 56, the kernel that was shipped in the beta. we're going to need a new kernel build tagged into rawhide soon, for this and other issues - the sooner the better, for testing purposes.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 David Woodhouse 2009-10-27 10:44:29 EDT
Adding additional repositories on NFS is also broken, I believe.
Comment 16 James Laska 2009-10-27 15:55:10 EDT
A new kernel is available in rawhide that contains this fix.  kernel-2.6.31.5-96.fc12 includes the patch noted by steved in comment#8.

* Tue Oct 13 2009 Steve Dickson <steved@redhat.com> 2.6.31.4-81
- Fixed hang during NFS installs (bz 528537)

(In reply to comment #15)
> Adding additional repositories on NFS is also broken, I believe.  

Hey David, there are a few hiccups around the yum repo dialogs in the installer.  We've got a few pinpointed, but I suspect others remain.  I don't have the bugs handy atm, but a few were resolved already around nfs repo's.  Can you file a new bug for any anaconda UI issues while editing repos?
Comment 17 Kamil Páral 2009-10-29 04:53:59 EDT
The new kernel fixed this problem for me.
Comment 18 Adam Williamson 2009-10-29 13:05:15 EDT
Dave, can you confirm so we can close this? -96 was tagged into F12 already, so we have a new enough build to include the fix.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Adam Williamson 2009-10-30 14:33:53 EDT
Ping - Dave, this is on the f12 blocker list and we're coming down to the release wire so it'd be great if you could confirm ASAP. Thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 20 Michal Jaegermann 2009-10-31 18:18:01 EDT
I tried a setup with anaconda version 12.41 and image files from  2009-10-30 rawhide.  At least initial installation stages did not require a workaround from a comment $4.  Anaconda was using NFSv3 without an explicit turning off v4 on a server.  OTOH I did not try a kickstart file but I was loading stage2 over NFS.
Comment 21 Adam Williamson 2009-11-02 17:19:10 EST
We really want to pare down the blocker list now. Given confirmation from two people I'm pretty confident this is fixed. Dave, please re-open if you can still reproduce a problem here...Steve, please advise if you think I'm closing this too soon.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 22 Chris Lumens 2009-11-12 14:23:07 EST
*** Bug 537067 has been marked as a duplicate of this bug. ***
Comment 23 Martin Gracik 2009-11-18 08:10:17 EST
*** Bug 529462 has been marked as a duplicate of this bug. ***
Comment 24 Geoff Levand 2009-11-18 13:44:46 EST
I tested this with the F12 final release on PS3 and it seems to be fixed.

-Geoff

Note You need to log in before you can comment on or make changes to this bug.