Bug 537266 - RFC: python3-babel
RFC: python3-babel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: babel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: Python3F13 537268
  Show dependency treegraph
 
Reported: 2009-11-12 18:54 EST by Dave Malcolm
Modified: 2010-12-02 16:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-02 16:53:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
python3 build of babel, based on babel.spec (2.91 KB, text/plain)
2009-11-12 18:55 EST, Dave Malcolm
no flags Details

  None (edit)
Description Dave Malcolm 2009-11-12 18:54:30 EST
I'm working on adding a python 3 stack to Fedora 13, parallel-installable with
the main python 2 stack:
https://fedoraproject.org/wiki/Features/Python3F13

There are two approaches I'm experimenting with to packaging modules for python
3:
  (a) create an separate specfile/srpm for the python 3 version
  (b) extend an existing specfile so that it emits a python3- subpackage as
part of the build.

See: https://fedoraproject.org/wiki/PackagingDrafts/Python3

I experimented and was able to use babel.spec to create a python3-babel.spec that builds, using 2to3 at the end of the %prep phase, with some other fixups; it should be parallel-installable with the python 2 babel.  

I haven't properly tested it yet, though.

Do you know what upstream's plans are for python 3 support?
Comment 1 Dave Malcolm 2009-11-12 18:55:54 EST
Created attachment 369356 [details]
python3 build of babel, based on babel.spec
Comment 2 Bug Zapper 2009-11-16 10:29:53 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Thomas Spura 2010-04-16 19:10:06 EDT
You can't just use 2to3 to do a python3 package for this 'because of a few reasons'.

See http://babel.edgewall.org/ticket/209


Don't know, if this bug should stay open till a decision.

Note You need to log in before you can comment on or make changes to this bug.