Bug 537268 - RFC: python3-jinja2
RFC: python3-jinja2
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-jinja2 (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Moschny
Fedora Extras Quality Assurance
:
Depends On: 537266
Blocks: Python3F13
  Show dependency treegraph
 
Reported: 2009-11-12 19:04 EST by Dave Malcolm
Modified: 2010-08-18 20:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 20:53:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Separate specfile that builds (adapted from python-jinja2.spec; no changelog). Barely tested. (2.84 KB, text/plain)
2009-11-12 19:06 EST, Dave Malcolm
no flags Details

  None (edit)
Description Dave Malcolm 2009-11-12 19:04:28 EST
I'm working on adding a python 3 stack to Fedora 13, parallel-installable with
the main python 2 stack:
https://fedoraproject.org/wiki/Features/Python3F13

There are two approaches I'm experimenting with to packaging modules for python
3:
  (a) create an separate specfile/srpm for the python 3 version
  (b) extend an existing specfile so that it emits a python3- subpackage as
part of the build.

See: https://fedoraproject.org/wiki/PackagingDrafts/Python3

I'm working towards getting sphinx working on Python 3.

I experimented and was able to use python-jinja2.spec to create a python3-jinja2.spec that builds, using 2to3 at the end of the %prep phase, with some other fixups; it should be parallel-installable with the python 2 python-jinja2.  

I haven't properly tested it yet, though.

Do you know what upstream's plans are for python 3 support?  

I saw this:
http://groups.google.com/group/pocoo-libs/browse_thread/thread/efda29f8bddba84f/56aae1cd46bdadba?lnk=gst&q=python+3#56aae1cd46bdadba "Jinja2 for Python 3"
> I'm happy to accept a Jinja2 python3 port assuming it works in a way 
> that I just have to run it through 2to3 to get an updated version (or
> the other way round).
> Maintaining two completely independent versions at the same time is 
> tedious and I don't have the time for it :( "

If I sent a patch that added a python3-jinja2 subpackage to the python-jinja2 build, would that be acceptable by you?

Thanks!
Comment 1 Dave Malcolm 2009-11-12 19:06:31 EST
Created attachment 369357 [details]
Separate specfile that builds (adapted from python-jinja2.spec; no changelog).  Barely tested.
Comment 2 Bug Zapper 2009-11-16 10:29:59 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Thomas Moschny 2009-11-28 11:43:59 EST
(In reply to comment #0)
> I experimented and was able to use python-jinja2.spec to create a
> python3-jinja2.spec that builds, using 2to3 at the end of the %prep phase, with
> some other fixups; it should be parallel-installable with the python 2
> python-jinja2.  
> 
> I haven't properly tested it yet, though.
> 
> Do you know what upstream's plans are for python 3 support?  
> 
> I saw this:
> http://groups.google.com/group/pocoo-libs/browse_thread/thread/efda29f8bddba84f/56aae1cd46bdadba?lnk=gst&q=python+3#56aae1cd46bdadba
> "Jinja2 for Python 3"
> > I'm happy to accept a Jinja2 python3 port assuming it works in a way 
> > that I just have to run it through 2to3 to get an updated version (or
> > the other way round).
> > Maintaining two completely independent versions at the same time is 
> > tedious and I don't have the time for it :( "
> 
> If I sent a patch that added a python3-jinja2 subpackage to the python-jinja2
> build, would that be acceptable by you?

Yes.

Reading http://groups.google.com/group/pocoo-libs/browse_thread/thread/468e2869a79a0737/1ec201d986cd843d, I think running 2to3 might not be enough.

Will have a look though.
Comment 4 Thomas Moschny 2010-02-06 07:34:57 EST
Just to let you know that I'm working on a specfile that will produce a python3-jinja2 subpackage.

Just talked to upstream, and they will be releasing a new version which should have the 2to3 call in the setup.py within the next few days.
Comment 5 Thomas Moschny 2010-02-10 13:41:55 EST
Ok, so here's what it currently looks like:
http://thm.fedorapeople.org/python-jinja2/python-jinja2.spec

Comments welcome.

Guess it doesn't make sense to commit that to rawhide yet, as long as bug 537266 blocks us?
Comment 6 Bug Zapper 2010-03-15 09:00:43 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Thomas Moschny 2010-07-13 18:32:04 EDT
Finally built python-jinja2-2.5-1 for rawhide, including a python3 subpackage. Please test. 

If it works well, we might consider issuing an F13 update as well. Therefore, not yet closing this bug.
Comment 8 Thomas Moschny 2010-08-18 20:53:05 EDT
Ok, seems there's not much interest in an F13 package.

Note You need to log in before you can comment on or make changes to this bug.