Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 591827 - Crash due to non-threadsafe use of libgcrypt/gnutls
Summary: Crash due to non-threadsafe use of libgcrypt/gnutls
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gtk-vnc
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Daniel Berrangé
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 09:50 UTC by Daniel Berrangé
Modified: 2010-11-15 13:58 UTC (History)
2 users (show)

Fixed In Version: gtk-vnc-0.3.10-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 537489
Environment:
Last Closed: 2010-11-15 13:58:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fix gcrypt threading initialization (1.70 KB, patch)
2010-05-13 09:52 UTC, Daniel Berrangé
no flags Details | Diff

Description Daniel Berrangé 2010-05-13 09:50:48 UTC
+++ This bug was initially created as a clone of Bug #537489 +++

abrt detected a crash.

Comment: Trying to open a console in virt-manager of a machine on another host.
Attached file: backtrace
cmdline: python /usr/share/virt-manager/virt-manager.py
component: python
executable: /usr/bin/python
kernel: 2.6.31.5-127.fc12.x86_64
package: python-2.6.2-2.fc12
rating: 3
reason: Process was terminated by signal 6

--- Additional comment from dmalcolm@redhat.com on 2009-11-13 15:35:19 EST ---

Thanks for filing this bug.

From the backtrace, it looks like an assertion failed; frame 2 of thread 1 has:
  Assertion `*lock == ((ath_mutex_t) 0)' failed.
in _gcry_ath_mutex_lock, deep inside gvnc_start_tls (frame 21) within gvnc_initialize (frame 24).

So it looks like an assertion failure deep inside gvnc's TLS code, which causes the process to abort.

Reassigning component from "python" to "virt-manager" in the hope that someone with knowledge of that domain can assign it to a more appropriate component.

He or she will probably want to know which version of virt-manager, libvirt, etc you have installed.

--- Additional comment from jlayton@redhat.com on 2009-11-13 15:41:49 EST ---

Here's the versions of those two:

virt-manager-0.8.0-7.fc12.noarch
libvirt-0.7.1-15.fc12.x86_64

...let me know if you need other info.

--- Additional comment from berrange@redhat.com on 2009-12-17 13:42:02 EST ---

Fix built in gtk-vnc-0.3.10-2.fc12

This fixes the problem as far as GTK-VNC is concerned. It'll likely still crash though because of an identical bug in libvirt https://bugzilla.redhat.com/show_bug.cgi?id=544305

Comment 2 Daniel Berrangé 2010-05-13 09:52:12 UTC
Created attachment 413700 [details]
Fix gcrypt threading initialization

Comment 3 RHEL Program Management 2010-05-13 14:06:24 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Daniel Berrangé 2010-05-13 15:06:57 UTC
Fix built in gtk-vnc-0.3.10-2.el6

Comment 6 Radek Lat 2010-10-11 09:38:55 UTC
Could you please retest with the latest RC?
http://download.devel.redhat.com/rel-eng/RHEL6.0-RC-4/

Comment 7 Daniel Berrangé 2010-10-13 12:28:34 UTC
This is quite hard to reproduce, but in my testing there were no further crashes.

Comment 8 Radek Lat 2010-10-13 14:44:52 UTC
Thank you for your report.

Comment 9 releng-rhel@redhat.com 2010-11-15 13:58:40 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.