Bug 53750 - installkernel doesn't know about grub!
Summary: installkernel doesn't know about grub!
Status: CLOSED DUPLICATE of bug 53557
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: mkinitrd   
(Show other bugs)
Version: roswell
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-17 19:19 UTC by lars
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-26 16:04:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description lars 2001-09-17 19:19:11 UTC
Description of Problem:

/sbin/installkernel doesn't know about grub.  If a user happens to have the
 "lilo" binary installed and types "make install" in a kernel source tree,
they risk replacing grub with lilo.  If they have an old but syntactically
correct lilo.conf, they could render themselves unbootable.

Version-Release number of selected component (if applicable):

kernel-2.4.7-2

How Reproducible:

cat /sbin/installkernel

Additional Information:

Maybe there should be a file in /etc/sysconfig that indicates whether the
user is using lilo or grub as the main bootloader?

Comment 1 Erik Troan 2002-05-21 22:25:48 UTC

*** This bug has been marked as a duplicate of 53557 ***


Note You need to log in before you can comment on or make changes to this bug.