Bug 53557 - /sbin/installkernel runs lilo also when using GRUB
/sbin/installkernel runs lilo also when using GRUB
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: mkinitrd (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 53561 53750 55141 58023 61158 63737 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-11 13:47 EDT by Tobias Ringstrom
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-26 17:40:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tobias Ringstrom 2001-09-11 13:47:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010809

Description of problem:
The installation program installs the LILO RPM, even when GRUB is selected
as the boot loader, and also creates /etc/lilo.

When running "make install" for a kernel, /sbin/installkernel is run, which
in turn runs lilo, and then overwrites the GRUB boot sector.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use GRUB as boot loaded, and have LILO installed also
2. "make install" for a kernel
3. No more GRUB...
	

Actual Results:  The GRUB bootsector is overwritten.

Expected Results:  LILO should not be installed and used if GRUB is
selected as boot loaded during the installation.

Additional info:
Comment 1 Erik Troan 2002-05-21 18:25:00 EDT
*** Bug 53561 has been marked as a duplicate of this bug. ***
Comment 2 Erik Troan 2002-05-21 18:25:42 EDT
*** Bug 53750 has been marked as a duplicate of this bug. ***
Comment 3 Erik Troan 2002-05-21 18:26:44 EDT
*** Bug 55141 has been marked as a duplicate of this bug. ***
Comment 4 Erik Troan 2002-05-21 18:32:06 EDT
*** Bug 61158 has been marked as a duplicate of this bug. ***
Comment 5 Erik Troan 2002-05-21 18:34:35 EDT
*** Bug 63737 has been marked as a duplicate of this bug. ***
Comment 6 Erik Troan 2002-05-21 19:06:08 EDT
*** Bug 58023 has been marked as a duplicate of this bug. ***
Comment 7 Erik Troan 2002-05-26 17:40:20 EDT
The new version of grubby now support lilo; new-kernel-pkg needs to be updated
to use it to resolve this bug properly.
Comment 8 Erik Troan 2002-06-19 22:35:16 EDT
fixed in latest mkinitrd (lilo/grub should be updated properly)

Note You need to log in before you can comment on or make changes to this bug.