Bug 537798 - [abrt] crash detected in gnome-panel-2.28.0-13.fc12 (/usr/libexec/clock-applet)
[abrt] crash detected in gnome-panel-2.28.0-13.fc12 (/usr/libexec/clock-applet)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
abrt_hash:2664fbc67530961b33e0e7d01a3...
: Triaged
: 523871 530903 533428 537237 537532 537592 537721 538647 539343 539404 539897 541649 541789 543090 544521 545021 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-16 06:51 EST by Douglas Furlong
Modified: 2010-03-11 02:24 EST (History)
17 users (show)

See Also:
Fixed In Version: gnome-panel-2.28.0-16.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-11 02:24:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (9.15 KB, text/plain)
2009-11-16 06:51 EST, Douglas Furlong
no flags Details

  None (edit)
Description Douglas Furlong 2009-11-16 06:51:55 EST
abrt detected a crash.

Attached file: backtrace
cmdline: /usr/libexec/clock-applet --oaf-activate-iid=OAFIID:GNOME_ClockApplet_Factory --oaf-ior-fd=29
component: gnome-panel
executable: /usr/libexec/clock-applet
kernel: 2.6.31.5-127.fc12.i686.PAE
package: gnome-panel-2.28.0-13.fc12
rating: 4
reason: Process was terminated by signal 6
Comment 1 Douglas Furlong 2009-11-16 06:51:58 EST
Created attachment 369674 [details]
File: backtrace
Comment 2 TK009 2009-11-17 08:51:24 EST
*** Bug 537721 has been marked as a duplicate of this bug. ***
Comment 3 TK009 2009-11-17 08:55:01 EST
*** Bug 523871 has been marked as a duplicate of this bug. ***
Comment 4 TK009 2009-11-17 08:56:29 EST
*** Bug 533428 has been marked as a duplicate of this bug. ***
Comment 5 TK009 2009-11-17 08:57:08 EST
*** Bug 537592 has been marked as a duplicate of this bug. ***
Comment 6 TK009 2009-11-17 08:57:55 EST
*** Bug 537532 has been marked as a duplicate of this bug. ***
Comment 7 TK009 2009-11-17 08:59:53 EST
*** Bug 530903 has been marked as a duplicate of this bug. ***
Comment 8 TK009 2009-11-20 13:59:34 EST
*** Bug 539343 has been marked as a duplicate of this bug. ***
Comment 9 Joerg Stephan 2009-11-20 14:04:05 EST
*** Bug 537237 has been marked as a duplicate of this bug. ***
Comment 10 Joerg Stephan 2009-11-20 14:40:56 EST
*** Bug 539404 has been marked as a duplicate of this bug. ***
Comment 11 Ray Strode [halfline] 2009-12-01 13:26:09 EST
*** Bug 539897 has been marked as a duplicate of this bug. ***
Comment 12 Ray Strode [halfline] 2009-12-01 13:40:06 EST
*** Bug 538647 has been marked as a duplicate of this bug. ***
Comment 13 Ray Strode [halfline] 2009-12-01 13:46:44 EST
*** Bug 541649 has been marked as a duplicate of this bug. ***
Comment 14 Ray Strode [halfline] 2009-12-01 13:54:17 EST
*** Bug 541789 has been marked as a duplicate of this bug. ***
Comment 15 Ray Strode [halfline] 2009-12-01 13:55:57 EST
*** Bug 543090 has been marked as a duplicate of this bug. ***
Comment 16 Matthias Clasen 2009-12-08 13:25:50 EST
*** Bug 545021 has been marked as a duplicate of this bug. ***
Comment 17 Matthias Clasen 2009-12-08 13:25:59 EST
*** Bug 544521 has been marked as a duplicate of this bug. ***
Comment 18 Ray Strode [halfline] 2009-12-08 14:46:12 EST
So the code has:

/* Used to count the number of clock instances. It's there to know when we•
 * should free resources that are shared. */•
static int clock_numbers = 0;•

[...]

⟾       clock_numbers++;•
⟾       e_passwords_init ();•


[...]

#ifdef HAVE_LIBECAL•
⟾       if (clock_numbers > 0) {•
⟾       ⟾       e_passwords_shutdown ();•
⟾       ⟾       clock_numbers--;•
⟾       }•
#endif•

The docs don't mention e_passwords_init being ref counted internally, so i don't know why we're calling init() and shutdown() more than once.

Looking at the code e-d-s code, there's a bug in shutdown:

def WITH_GNOME_KEYRING•
⟾       g_free (default_keyring);•
#endif•

default_keyring isn't getting nullified after the free.  This makes the shutdown function not idempotent.

Two possible fixes:

1) nullify default_keyring on free
2) only call shutdown when clock_numbers decrements to 0.

Given that clock_numbers is only used for shutdown and init, i'll assume it's original intent was for 2 to happen and someone just had a think-o.
Comment 19 Fedora Update System 2009-12-08 15:11:52 EST
gnome-panel-2.28.0-16.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gnome-panel-2.28.0-16.fc12
Comment 20 Felix Möller 2009-12-08 19:30:30 EST
I have updated to gnome-panel-2.28.0-16.fc12 from the page mentioned above. Sadly I am still not able to press ALT-F2 (i.e. open the run dialog).

I installed all debug packages and attached gdb to gnome-panel:
(gdb) bt
#0  0x004abbea in gmenu_tree_directory_get_contents (directory=0x0) at gmenu-tree.c:1008
#1  0x0807de85 in get_all_applications_from_dir (directory=<value optimized out>, list=<value optimized out>)
    at panel-run-dialog.c:833
#2  0x0807dfa7 in get_all_applications () at panel-run-dialog.c:873
#3  0x0807e03d in panel_run_dialog_add_items_idle (dialog=<value optimized out>) at panel-run-dialog.c:905
#4  0x00189312 in g_idle_dispatch (source=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>)
    at gmain.c:4065
#5  0x0018b128 in g_main_dispatch (context=<value optimized out>) at gmain.c:1960
#6  IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2513
#7  0x0018ea58 in g_main_context_iterate (context=<value optimized out>, block=<value optimized out>, 
    dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2591
#8  0x0018eecf in IA__g_main_loop_run (loop=<value optimized out>) at gmain.c:2799
#9  0x07c57b99 in IA__gtk_main () at gtkmain.c:1218
#10 0x08060fea in main (argc=<value optimized out>, argv=<value optimized out>) at main.c:110
Comment 21 Ray Strode [halfline] 2009-12-09 11:30:27 EST
Hi Felix,

This bug was meant to address a crash in the clock applet, not the run dialog.  If you are one of the many duplicate bug reports on this bug, you may have been misduped.  Can you reopen your bug report?
Comment 22 Felix Möller 2009-12-09 16:10:42 EST
I have been the first dupe of this report in comment #2 i reported my issue now at bug #546043.
Comment 23 Fedora Update System 2009-12-09 23:20:39 EST
gnome-panel-2.28.0-16.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-panel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12992
Comment 24 Fedora Update System 2009-12-17 23:39:53 EST
gnome-panel-2.28.0-16.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-panel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12992
Comment 25 Fedora Update System 2010-03-11 02:24:08 EST
gnome-panel-2.28.0-16.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.