Bug 53802 - printconf and apacheconf crash while loading component of PyXML
printconf and apacheconf crash while loading component of PyXML
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: printconf (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
Ben Levenson
:
: 53924 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-19 04:18 EDT by Tuomo Soini
Modified: 2007-04-18 12:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-27 09:19:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tuomo Soini 2001-09-19 04:18:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010917

Description of problem:
apacheconf crashes with ImportError: No module named xslt.Processor
printconf-gui crashes with ImportError: No module named utils

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. upgrade to rawhide-20010917
2. run printconf-gui
3. run apacheconf-gui



Actual Results:  everyghin seems to be ok. But when booting to new rawhide
system lpd informs:

Starting lpd: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import printconf_backend
  File "/usr/share/printconf/util/printconf_backend.py", line 28, in ?
    from printconf_conf import *
  File "/usr/share/printconf/util/printconf_conf.py", line 81, in ?
    from xml.utils import qp_xml
ImportError: No module named utils
No Printers Defined                                        [  OK  ]


Expected Results:  It should have worked

Additional info:

Seems like python in current rawhide is relly broken. This seems like
generic python problem, not PyXML while components are PyXML components.
printconf-gui on rawhide hasn't workes in some releases now. Last release
with working printconf-gui is some version before first roswell-beta
Comment 1 Andrew Meredith 2001-09-20 08:13:22 EDT
I have three rawhide based test systems. On the the more recently updated one
printconf is hosed, the other two are fine.

Working:

Raw Hide 20010827

printconf-gui-0.3.29-1
printconf-0.3.29-1
PyXML-0.6.5-4
printconf-gui-0.3.29-1
printconf-0.3.29-1
python-devel-1.5.2-35
python-docs-1.5.2-35
python-xmlrpc-1.4.5-0.7.x
pythonlib-1.28-1
python-1.5.2-35
python-tools-1.5.2-35

Hosed:

Raw Hide 20010917

printconf-gui-0.3.46-1
printconf-0.3.46-1
PyXML-0.6.5-4
python-xmlrpc-1.5.0-1
python-tools-2.2-0.3a3
python-docs-2.2-0.3a3
python-2.2-0.3a3
pythonlib-1.28-1
python-devel-2.2-0.3a3


Hope this helps

Andy M
Comment 2 Sammy 2001-09-20 12:25:43 EDT
Please see my report 53795 about phyton2.2....the problem is many packages
put their py files into /usr/lib/pyhton1.5/site-packages directory. The new
directory for 2.2 is under /usr/lib/python2.2 and the other packages are not
trasformed there and left under 1.5. I did try to transfer manually but could
not make it work. Somehoiw the new pyhton did not search those subdirectories.
Anyway, I would wait till the next release.
Comment 3 Joseph Fannin 2001-09-21 15:38:53 EDT
*** Bug 53924 has been marked as a duplicate of this bug. ***
Comment 4 Knut J BJuland 2001-09-26 15:40:46 EDT
There appear to be some problem in up2date also.
/usr/sbin/up2date:533: SyntaxWarning: name 'progressCurrent' is used prior to
global declaration
  def rpmCallback(what, amount, total, hdr, path):
/usr/sbin/up2date:533: SyntaxWarning: name 'hashesPrinted' is assigned to before
global declaration
  def rpmCallback(what, amount, total, hdr, path):
/usr/sbin/up2date:533: SyntaxWarning: name 'lastPercent' is assigned to before
global declaration
  def rpmCallback(what, amount, total, hdr, path):
/usr/sbin/up2date:533: SyntaxWarning: name 'progressTotal' is assigned to before
global declaration
  def rpmCallback(what, amount, total, hdr, path):
/usr/sbin/up2date:533: SyntaxWarning: name 'progressCurrent' is assigned to
before global declaration
  def rpmCallback(what, amount, total, hdr, path):
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: No module named rpm
Comment 5 Andrew Meredith 2001-09-26 16:30:43 EDT
I am confused as to the relationship between PyXML and up2date with respect to
the bug this report originally referenced. Maybe the previous comment is missing
a vital detail.
Comment 6 Knut J BJuland 2001-09-27 09:19:16 EDT
up2date is also using files in /usr/lib/python-1.5. Which it is not finding.
Comment 7 Crutcher Dunnavant 2001-11-26 11:58:05 EST
No effort has yet been made to make printconf work with python 2.x, this is not
a bug, yet.

Note You need to log in before you can comment on or make changes to this bug.