Bug 53924 - Printconf-backend 0.3.46-1 crashes at lpd startup
Summary: Printconf-backend 0.3.46-1 crashes at lpd startup
Status: CLOSED DUPLICATE of bug 53802
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: printconf   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-21 18:46 UTC by Joseph Fannin
Modified: 2007-04-18 16:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-21 18:48:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joseph Fannin 2001-09-21 18:46:47 UTC
Description of Problem:

    When starting lpd, printconf-backend crashes with a python backtrace
and no printers are available.  Starting printconf-gui produces the same
traceback.

Version-Release number of selected component (if applicable):

    0.4.46-1

How Reproducible:

    Start lpd or printconf-gui...  I have (had?) two printers defined
before upgrading to the most recent rawhide push (as of 9/21) via apt-rpm.
  (*All* packages on this system have been upgraded to the rawhide
version.)  The two printers are a postscript printer on lp0 and a Deskjet
882 (don't recall which driver) on usb/lp0.


Additional Information:

    Python backtrace follows:

Starting lpd: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import printconf_backend
  File "/usr/share/printconf/util/printconf_backend.py", line 28, in ?
    from printconf_conf import *
  File "/usr/share/printconf/util/printconf_conf.py", line 81, in ?
    from xml.utils import qp_xml
ImportError: No module named utils
No Printers Defined                                        [  OK  ]

Comment 1 Joseph Fannin 2001-09-21 18:48:04 UTC
That package version in the body should be 0.3.46-1, my mistake.

Comment 2 Joseph Fannin 2001-09-21 19:38:58 UTC
Bahhh... this is a dup, I'm sorry for the spam.

*** This bug has been marked as a duplicate of 53802 ***


Note You need to log in before you can comment on or make changes to this bug.