This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 538123 - Memory error in boot after preupgrade
Memory error in boot after preupgrade
Status: CLOSED DUPLICATE of bug 538118
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-17 12:19 EST by Charley Wang
Modified: 2014-01-21 18:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-17 13:01:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charley Wang 2009-11-17 12:19:44 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Charley Wang 2009-11-17 12:25:14 EST
Ack! I apologize, I grazed the enter key by mistake.

What I meant to say was:

Description of problem:
After attempting to preupgrade from F11, I encountered a memory error in boot during the preupgrade reboot. The error report was saved, but I can't seem to find it on my file system and I'm not sure what it's called. Subsequent reboots occur in F11.


How reproducible:
Only happened once. Afterwards preupgrade ceases working.


Steps to Reproduce:
1. Attempt to preupgrade with insufficient space in boot
df /boot returns:
/dev/sda1               198337    179278      8819  96% /boot
2. Reboot

Actual results:
Throws an error, after power cycling to reboot the machine restarts in F11


Expected results:
Upgrade to F12
Comment 2 Charley Wang 2009-11-17 12:26:34 EST
Preupgrade output on subsequent runs: (I believe the warning about .preconf was there the first time as well) 

/usr/lib/python2.6/site-packages/yum/__init__.py:203: UserWarning: Use .preconf instead of passing args to _getConfig
  warnings.warn('Use .preconf instead of passing args to _getConfig')
Loaded plugins: blacklist, refresh-packagekit, whiteout
Detected in-progress upgrade to Fedora 12 (Constantine)
preupgrade-main (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-12&arch=$basearch
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-12&arch=x86_64
preupgrade (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/12/Fedora/$basearch/os
  now: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/12/Fedora/x86_64/os
preupgrade-adobe-linux-i386 (baseurl) 
  url: http://linuxdownload.adobe.com/linux/i386/
  now: http://linuxdownload.adobe.com/linux/i386/
preupgrade-fedora (mirrorlist) 
  url: https://mirrors.fedoraproject.org/metalink?repo=fedora-12&arch=x86_64
  now: https://mirrors.fedoraproject.org/metalink?repo=fedora-12&arch=x86_64
unknown metadata being downloaded: metalink
preupgrade-flash (baseurl) 
  url: http://www.dfm.uninsubria.it/compiz/fusion-testing/flashplayer.x86_64/
  now: http://www.dfm.uninsubria.it/compiz/fusion-testing/flashplayer.x86_64/
preupgrade-updates (mirrorlist) 
  url: https://mirrors.fedoraproject.org/metalink?repo=updates-released-f12&arch=x86_64
  now: https://mirrors.fedoraproject.org/metalink?repo=updates-released-f12&arch=x86_64
unknown metadata being downloaded: metalink
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 764, in <module>
    widgets = PreUpgradeGtk()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 376, in __init__
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 259, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 436, in main_preupgrade
    download_progressbar=self.dnlProgress)
  File "/usr/lib/python2.6/site-packages/preupgrade/__init__.py", line 130, in setup
    self.complete_repo_setup()
  File "/usr/lib/python2.6/site-packages/preupgrade/__init__.py", line 328, in complete_repo_setup
    repo._grabfunc.opts.user_agent = __user_agent__
AttributeError: 'NoneType' object has no attribute 'opts'
Comment 3 Will Woods 2009-11-17 13:01:53 EST

*** This bug has been marked as a duplicate of bug 538118 ***

Note You need to log in before you can comment on or make changes to this bug.