Bug 538152 - Preupgrade F11>F12 not working
Preupgrade F11>F12 not working
Status: CLOSED DUPLICATE of bug 538118
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-11-17 13:54 EST by Guil Barros
Modified: 2014-01-21 18:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-11-17 14:03:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Guil Barros 2009-11-17 13:54:42 EST
Description of problem:
preupgrade is failing but reporting all good. When i reboot it doesnt boot into the installer as there is none.

Version-Release number of selected component (if applicable):

How reproducible:
every time

Steps to Reproduce:
[root@x301 ~]# preupgrade
/usr/lib/python2.6/site-packages/yum/__init__.py:203: UserWarning: Use .preconf instead of passing args to _getConfig
  warnings.warn('Use .preconf instead of passing args to _getConfig')
Loaded plugins: blacklist, fastestmirror, refresh-packagekit, whiteout
preupgrade-main (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-12&arch=$basearch
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-12&arch=i386
Loading mirror speeds from cached hostfile
 * fedora: fedora.fastsoft.net
 * updates: linux.nssl.noaa.gov
preupgrade (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/12/Fedora/$basearch/os
  now: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/12/Fedora/i386/os
Checking for new repos for mirrors
 * preupgrade-main: fedora.fastsoft.net
preupgrade-fedora (mirrorlist) 
  url: https://mirrors.fedoraproject.org/metalink?repo=fedora-12&arch=i386
  now: https://mirrors.fedoraproject.org/metalink?repo=fedora-12&arch=i386
Checking for new repos for mirrors
unknown metadata being downloaded: metalink
preupgrade-updates (mirrorlist) 
  url: https://mirrors.fedoraproject.org/metalink?repo=updates-released-f12&arch=i386
  now: https://mirrors.fedoraproject.org/metalink?repo=updates-released-f12&arch=i386
Checking for new repos for mirrors
 * preupgrade-fedora: fedora.fastsoft.net
unknown metadata being downloaded: metalink
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 240, in on_assistant_apply
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 259, in _do_main
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 436, in main_preupgrade
  File "/usr/lib/python2.6/site-packages/preupgrade/__init__.py", line 130, in setup
  File "/usr/lib/python2.6/site-packages/preupgrade/__init__.py", line 328, in complete_repo_setup
    repo._grabfunc.opts.user_agent = __user_agent__
AttributeError: 'NoneType' object has no attribute 'opts'
Comment 1 Guil Barros 2009-11-17 14:03:40 EST

*** This bug has been marked as a duplicate of bug 538118 ***

Note You need to log in before you can comment on or make changes to this bug.