Bug 538233 - kdepim builds 8 hours with VTA
kdepim builds 8 hours with VTA
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
: 539697 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-17 19:02 EST by nucleo
Modified: 2010-02-11 11:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-11 11:50:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rh538233.ii.bz2 (160.41 KB, application/x-bzip2)
2009-12-15 11:28 EST, Jakub Jelinek
no flags Details

  None (edit)
Description nucleo 2009-11-17 19:02:36 EST
Description of problem:

kdepim builds more than 8 hours with var tracking assignments.
http://koji.fedoraproject.org/koji/buildinfo?buildID=140724

But with -fno-var-tracking-assignments kdepim builds less than 1 hour. 
https://koji.fedoraproject.org/koji/taskinfo?taskID=1813288

Version-Release number of selected component (if applicable):
gcc 4.4.2-7.fc12

How reproducible:
Every time.
Comment 1 Rex Dieter 2009-11-23 13:50:42 EST
Narrowed it down to kmail/globalsettings_base.cpp (generated file).

Here's a temporary workaround we'll be using:
http://cvs.fedoraproject.org/viewvc/devel/kdepim/kdepim-4.3.3-kmail_globalsettings_no_var_tracking.patch
Comment 2 Alexandre Oliva 2009-11-23 18:28:03 EST
Any chance you still have that build tree around, and could get me a preprocessed version of this fle?  Making some algorithmic and memory improvements in VTA is next on my plate, and it would be nice to confirm, when I get a fix for this problem, without building all of kdepim.  Thanks,
Comment 3 Jakub Jelinek 2009-12-15 11:26:16 EST
*** Bug 539697 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Jelinek 2009-12-15 11:28:15 EST
Created attachment 378546 [details]
rh538233.ii.bz2

Preprocessed source.
Comment 5 Jakub Jelinek 2010-01-13 04:03:48 EST
Please try http://kojipkgs.fedoraproject.org/packages/gcc/4.4.2/24.fc12/
Comment 6 Rex Dieter 2010-01-19 12:36:16 EST
Confirmed better using gcc-4.4.2-26.fc12.x86_64
Comment 7 Jakub Jelinek 2010-02-11 11:50:50 EST
Should be fixed in gcc-4.4.3-4.fc12.

Note You need to log in before you can comment on or make changes to this bug.