Bug 538303 - Review Request: rubygem-minitest - Small and fast replacement for ruby's huge and slow test/unit
Summary: Review Request: rubygem-minitest - Small and fast replacement for ruby's huge...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 539442
TreeView+ depends on / blocked
 
Reported: 2009-11-18 08:32 UTC by Matthew Kent
Modified: 2015-03-19 09:40 UTC (History)
5 users (show)

Fixed In Version: 1.4.2-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-24 17:54:53 UTC
Type: ---
mtasaka: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Matthew Kent 2009-11-18 08:32:28 UTC
Spec URL: http://magoazul.com/wip/SPECS/rubygem-minitest.spec
SRPM URL: http://magoazul.com/wip/SRPMS/rubygem-minitest-1.4.2-1.fc13.src.rpm
Description: minitest/unit is a small and fast replacement for ruby's huge and slow test/unit. This is meant to be clean and easy to use both as a regular test writer and for language implementors that need a minimal set of methods to bootstrap a working unit test suite.

miniunit/spec is a functionally complete spec engine.

miniunit/mock, by Steven Baker, is a beautifully tiny mock object framework.

f13 build: https://koji.fedoraproject.org/koji/taskinfo?taskID=1813620

mkent@fedora-devel-chef:~/rpmbuild/SPECS$ rpmlint rubygem-minitest.spec /var/tmp/results/rubygem-minitest-*
rubygem-minitest-doc.noarch: W: no-documentation
rubygem-minitest-doc.noarch: W: hidden-file-or-dir /usr/lib/ruby/gems/1.8/gems/minitest-1.4.2/.autotest
rubygem-minitest-doc.noarch: W: misspelled-macro /usr/lib/ruby/gems/1.8/doc/minitest-1.4.2/ri/MiniTest/Unit/output%3d-c.yaml %3d
rubygem-minitest-doc.noarch: W: misspelled-macro /usr/lib/ruby/gems/1.8/doc/minitest-1.4.2/ri/MiniTest/Assertions/_assertions%3d-i.yaml %3d
rubygem-minitest-doc.noarch: W: misspelled-macro /usr/lib/ruby/gems/1.8/doc/minitest-1.4.2/ri/MiniTest/Unit/TestCase/passed%3f-i.yaml %3f
rubygem-minitest-doc.noarch: W: misspelled-macro /usr/lib/ruby/gems/1.8/doc/minitest-1.4.2/ri/MiniTest/Spec/nuke_test_methods%21-c.yaml %21
3 packages and 1 specfiles checked; 0 errors, 6 warnings.

The .autotest file seems valid and can be used by ZenTest autotest, though I'm not familiar with it's operation.

Comment 1 Mamoru TASAKA 2009-11-21 16:45:00 UTC
I will take this. Instead I will appreciate it if you would
review my rubygem-marc review request (bug 539606)

Comment 2 Mamoru TASAKA 2009-11-21 17:24:30 UTC
For 1.4.2-1:

* Source
  - http://gems.rubyforge.org/gems/minitest-1.4.2.gem works,
    so please use this.

* Requires/BuildRequires
  - Would you check if "Requires: rubygem(hoe)" is really needed?

Comment 3 Matthew Kent 2009-11-21 20:04:44 UTC
Hi! Will take a look at your package shortly.

(In reply to comment #2)
> For 1.4.2-1:
> 
> * Source
>   - http://gems.rubyforge.org/gems/minitest-1.4.2.gem works,
>     so please use this.
> 

Ah your right, didn't see the nice redirection they've done.

> * Requires/BuildRequires
>   - Would you check if "Requires: rubygem(hoe)" is really needed?  

Seems to be. The Rakefile uses hoe's lib/hoe/test.rb to provide the following tasks:

rake test                  # test      # Run the test suite.
rake test_deps             # test      # Show which test files fail when run alone.

Comment 4 Mamoru TASAKA 2009-11-21 20:19:52 UTC
(In reply to comment #3)
> > * Requires/BuildRequires
> >   - Would you check if "Requires: rubygem(hoe)" is really needed?  
>
> Seems to be. The Rakefile uses hoe's lib/hoe/test.rb to provide the following
> tasks:

However
- In my opinition, to begin with Rakefile is usually somewhat similar
  with Makefiles on autotool based tarball. So I usually put Rakefile
  to -doc subpackage as I don't think people usually need Rakefile.

- As you know usually I always request to execute "rake test" in
  rpmbuild (i.e. executing test should be done by _us_, like "make check").
  If the dependency for "rake test" is needed, perhaps we have to
  add "Requires: rubygem(rake)" (not BuildRequires) for binary gem-based
  rpm, which I think is not desired.

Comment 5 Matthew Kent 2009-11-21 20:22:29 UTC
Spec URL: http://magoazul.com/wip/SPECS/rubygem-minitest.spec
SRPM URL: http://magoazul.com/wip/SRPMS/rubygem-minitest-1.4.2-2.fc13.src.rpm

* Sat Nov 21 2009 Matthew Kent <mkent@magoazul.com> - 1.4.2-2
- Better Source (#538303).
- More standard permissions on files.

Comment 6 Matthew Kent 2009-11-21 20:30:53 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > > * Requires/BuildRequires
> > >   - Would you check if "Requires: rubygem(hoe)" is really needed?  
> >
> > Seems to be. The Rakefile uses hoe's lib/hoe/test.rb to provide the following
> > tasks:
> 
> However
> - In my opinition, to begin with Rakefile is usually somewhat similar
>   with Makefiles on autotool based tarball. So I usually put Rakefile
>   to -doc subpackage as I don't think people usually need Rakefile.
> 
> - As you know usually I always request to execute "rake test" in
>   rpmbuild (i.e. executing test should be done by _us_, like "make check").
>   If the dependency for "rake test" is needed, perhaps we have to
>   add "Requires: rubygem(rake)" (not BuildRequires) for binary gem-based
>   rpm, which I think is not desired.  

Oh sorry! I missed the Requires line for hoe and was looking at the BuildRequires. Your right, the Requires for hoe isn't necessary. 

And putting the Rakefile in doc seems like a good idea.

Comment 7 Matthew Kent 2009-11-21 20:39:47 UTC
Spec URL: http://magoazul.com/wip/SPECS/rubygem-minitest.spec
SRPM URL: http://magoazul.com/wip/SRPMS/rubygem-minitest-1.4.2-3.fc13.src.rpm

* Sat Nov 21 2009 Matthew Kent <mkent@magoazul.com> - 1.4.2-3
- Drop Requires on hoe, only used by Rakefile (#538303).
- Move Rakefile to -doc (#538303).

Comment 8 Mamoru TASAKA 2009-11-22 16:23:31 UTC
-----------------------------------------------------------
  This package (rubygem-minitest) is APPROVED by mtasaka
-----------------------------------------------------------

Comment 9 Matthew Kent 2009-11-23 06:52:26 UTC
New Package CVS Request
=======================
Package Name: rubygem-minitest
Short Description: Small and fast replacement for ruby's huge and slow test/unit
Owners: mkent
Branches: F-11 F-12
InitialCC:

Comment 10 Kevin Fenzi 2009-11-24 02:11:44 UTC
cvs done.

Comment 11 Fedora Update System 2009-11-24 05:06:12 UTC
rubygem-minitest-1.4.2-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rubygem-minitest-1.4.2-3.fc11

Comment 12 Fedora Update System 2009-11-24 05:07:37 UTC
rubygem-minitest-1.4.2-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rubygem-minitest-1.4.2-3.fc12

Comment 13 Mamoru TASAKA 2009-11-24 17:54:53 UTC
Closing this one.

Comment 14 Fedora Update System 2009-11-25 14:59:52 UTC
rubygem-minitest-1.4.2-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2009-11-25 15:27:49 UTC
rubygem-minitest-1.4.2-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Michael Stahnke 2010-05-04 00:14:33 UTC
Any chance we could get a branch for EPEL5?  I am happy to co-maintain.

Comment 17 Matthew Kent 2010-05-04 06:28:56 UTC
Package Change Request
======================
Package Name: rubygem-minitest
New Branches: EL-5
Owners: mkent stahnma

Comment 18 Kevin Fenzi 2010-05-06 15:23:28 UTC
cvs done.

Comment 19 Tomas Hrcka 2015-02-17 21:13:27 UTC
Package Change Request
======================
Package Name: rubygem-minitest
New Branches: epel7
Owners: mkent stahnma humaton jstribny

Comment 20 Gwyn Ciesla 2015-02-17 21:25:53 UTC
Git done (by process-git-requests).

Comment 21 Fedora Update System 2015-02-17 22:23:51 UTC
rubygem-minitest-5.3.1-2.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/rubygem-minitest-5.3.1-2.el7

Comment 22 Anssi Johansson 2015-03-19 09:40:26 UTC
There is already rubygem-minitest in EL7. EPEL packages are not supposed to overlap with EL packages, so this update should be unpushed and retired from EPEL7.


Note You need to log in before you can comment on or make changes to this bug.