Bug 538422 - win2k3r2sp2 64-bit Guest VM with network type rtl8139 generates blue screen after running network test.
win2k3r2sp2 64-bit Guest VM with network type rtl8139 generates blue screen ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: 5.6
Assigned To: jason wang
Virtualization Bugs
: Triaged
Depends On:
Blocks: Rhel5KvmTier3
  Show dependency treegraph
 
Reported: 2009-11-18 09:53 EST by Issue Tracker
Modified: 2013-01-09 17:02 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-06 08:36:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
sosreport-anantyogin.ibm.com.57204-684776-cfaea0.tar.bz2 (2.00 MB, application/x-bzip2)
2009-11-18 09:55 EST, Joseph Kachuck
no flags Details
BSOD screen dump (23.12 KB, image/png)
2011-01-28 01:04 EST, Mike Cao
no flags Details

  None (edit)
Description Issue Tracker 2009-11-18 09:53:46 EST
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2009-11-18 09:53:48 EST
Event posted on 11-17-2009 07:01am EST by Glen Johnson

=Comment: #0=================================================
YOGANANTH SUBRAMANIAN <anantyog@in.ibm.com> -

---Problem Description---
win2k3r2sp2 64-bit Guest VM with network type rtl8139 generates a blue screen after
running network test.

Attachment: blue screen

Contact Information = anantyog@in.ibm.com

---uname output---
Linux bc1cn6 2.6.18-164.el5 #1 SMP Tue Aug 18 15:51:48 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

Machine Type = Hs-22

---Steps to Reproduce---
Steps to recreate:
1)Download Soap Stone Benchmark(http://soap-stone.sourceforge.net/) and IBM
java 1.4 for windows

2)use  win2k3r2sp2 64-bit as the server and win2k3r2sp2 32-bit as client (this
bug does not occur when
win2k3r2sp2 64-bit is the client)

3) Running the test will reset the  network interface on the server(win2k3r2sp2
64bit).

4)Then shutdown the server(win2k3r2sp2 64bit), which will generate a blue
screen.

---KVM Component Data---
Userspace tool common name: qemu/kvm
The userspace tool has the following bit modes: 64-bit
Userspace rpm: kvm-83-105.el5_4.7
Userspace tool obtained from project website:  na

Test cmd line:
server: java -jar soap-stone-full-0.952.jar server -server 10.168.1.2
client : java -jar soap-stone-full-0.952.jar client -server 10.168.1.2
-protocol [raw,rmi,http,soap] -size [100,1k,10k,100k,1m,10m] -tables -columns
avg

Qemu cmd line used:
/usr/libexec/qemu-kvm -name 'vm1'  -drive
file=/scratch/images/yogi/images/win2003r2-64.vm1.raw,boot=on -net
nic,vlan=0,macaddr=20:20:20:00:00:01  -net
tap,vlan=0,script=/home/yogi/qemu-ifup  -m 10240  -smp 4  -usbdevice tablet
-vnc :0

/usr/libexec/qemu-kvm -name 'vm2'  -drive
file=/scratch/images/yogi/images/win2003r2sp2-32.vm1.raw,boot=on -net
nic,vlan=0,macaddr=20:20:20:00:00:02  -net
tap,vlan=0,script=/home/yogi/qemu-ifup  -m 10240  -smp 4  -usbdevice tablet
-vnc :1

=Comment: #1=================================================
ANOOP C. VIJAYAN <anoop.vijayan@in.ibm.com> -
Does the problem occur with other types of card (e1000, virtio)?

Also check if the following help
1. Adding the option "-cpu pentium3"
3. Limiting the guest memory to <4GB

=Comment: #2=================================================
YOGANANTH SUBRAMANIAN <anantyog@in.ibm.com> -
This error does not occur with both e1000 and virtio
Could not boot 64bit windows with -cpu peintium3
Error still occurs with memory less then 4Gb

=Comment: #3=================================================
ANOOP C. VIJAYAN <anoop.vijayan@in.ibm.com> -
Can you upgrade the driver
(http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=6&PFid=6&Level=5&Conn=4&DownTypeID=3&GetDown=false)
and see if it helps?

=Comment: #4=================================================
YOGANANTH SUBRAMANIAN <anantyog@in.ibm.com> -
I tried the driver u had mentioned and the issue still occurs, the test fails and the guest hangs
during shutdown, but thr is no blue screen, guest hangs and fails to shutdown.
This event sent from IssueTracker by jkachuck  [IBM-LTC]
 issue 366532
Comment 2 Issue Tracker 2009-11-18 09:53:51 EST
Event posted on 11-18-2009 02:05am EST by Glen Johnson

------- Comment From anantyog@in.ibm.com 2009-11-18 01:53 EDT-------
(In reply to comment #9)
> Hello,
> Please attach a sosreport from the host running the VM. Please also
confirm if
> this issue occurs if you use the e1000 module.
>
> Thank You
> Joe Kachuck
>
> jkachuck assigned to issue for IBM-LTC.
>
> Status set to: Waiting on Client

This issue does not occur with  win2k3r2sp2 64-bit Guest and e1000 module.

Internal Status set to 'Waiting on Support'
Status set to: Waiting on Tech

This event sent from IssueTracker by jkachuck  [IBM-LTC]
 issue 366532
Comment 3 Joseph Kachuck 2009-11-18 09:55:41 EST
Created attachment 370098 [details]
sosreport-anantyogin.ibm.com.57204-684776-cfaea0.tar.bz2
Comment 9 RHEL Product and Program Management 2011-01-11 16:05:52 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2011-01-11 17:47:43 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 12 Mike Cao 2011-01-28 00:39:33 EST
Reproduced on kvm-83-224.el5
guest info :
java-jdk-1.6.0_23
soap-stone-full-0.952.jar

steps:
1.start 2 VMs;
win2k3 64bit guest :
#/usr/libexec/qemu-kvm  -M rhel5.6.0 -m 2G -smp 2 -name win2k3_64 -uuid 12bb419b-8730-cbbd-b0d9-168fa4225b6d -monitor stdio -boot dc -drive file=/home/win03_64,if=ide,boot=on,format=raw,cache=none -net nic,macaddr=54:52:00:0e:bf:ae,vlan=0 -net tap,script=/etc/qemu-ifup,vlan=0 -serial pty -parallel none -usb -vnc :1 -k en-gb -vga cirrus -balloon virtio 
win2k3 32bit guest:
#/usr/libexec/qemu-kvm  -M rhel5.6.0 -m 2G -smp 2 -name win2k3_32 -uuid 22bb419b-8730-cbbd-b0d9-168fa4225b6d -monitor stdio -boot dc -drive file=/home/win03_32,if=ide,boot=on,format=raw,cache=none -net nic,macaddr=14:52:00:0e:bf:ae,vlan=0 -net tap,script=/etc/qemu-ifup,vlan=0 -serial pty -parallel none -usb -vnc :2 -k en-gb -vga cirrus -balloon virtio -cdrom /home/x86/en_win_srv_2003_r2_enterprise_with_sp2_cd1_X13-05460.iso
2.start soap server in windows 2003 64 bit guest
#java -jar soap-stone-full-0.952.jar server -server <win2k3_64 ip>
3.start soap server in windows 2003 64 bit guest
#java -jar soap-stone-full-0.952.jar client -server <win2k3_64 ip>
-protocol [raw,rmi,http,soap] -size [100,1k,10k,100k,1m,10m] -tables -columns
avg
4.use ctrl+c terminate soap-stone server
5 #shutdown -t 0 -r  in windows 2003 64 bit guest

Actual Results:
BOSD occurs in 2003 64 bit guest
Comment 13 Mike Cao 2011-01-28 01:04:29 EST
Created attachment 475730 [details]
BSOD screen dump

Note You need to log in before you can comment on or make changes to this bug.