Bug 53862 - up2date
up2date
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
: 54294 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-20 07:34 EDT by John Killian O'Brien
Modified: 2015-01-07 18:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-20 07:34:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Killian O'Brien 2001-09-20 07:34:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
I have the latest abiword from the AbiSource web page
(abiword-gtk-0.9.2-1.i386.rpm). When I run up2date, it insists on replacing
this with abiword-0.7.13-2

The reason for this seems to be that while AbiSource have "Release : 1" in
their rpm header, RedHat have "Release : 2".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. download abiword-gtk-0.9.2-1.i386.rpm from http://www.abisource.com/
2. Install with rpm -Uvh *.rpm
3. Run up2date --nox -u	

Actual Results:  Version 0.9.2-1 is replaced with 0.7.13

Expected Results:  up2date should report that the system is fully
up-to-date and there are no packages to upgrade

Additional info:

Clearly, I can get around this by upgrading packages individually or, I
believe, by getting the source files and building my own rpm.

The use of epochs _and_ version numbers has the potential for lots of this
kind of error. I've seen similar problems before, but I didn't know about
epochs then, so didn't report them.
Comment 1 Mihai Ibanescu 2001-09-20 11:56:57 EDT
This is the correct behaviour since Red Hat's rpm package has a greater epoch
than   
the one provided by AbiSource. It's not because of the release number, but of
the epoch.

Red Hat can only guarantee that RHN works fine with its own rpms. Third party rpms  
may cause problem, and this is the case with AbiSource's.

This is NOTABUG, but it's confusing nonetheless. Closing.
Comment 2 Mihai Ibanescu 2001-10-03 14:53:30 EDT
*** Bug 54294 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.