Bug 53866 - (MGA 400 AGP) xawtv + switching resolution = lockup
(MGA 400 AGP) xawtv + switching resolution = lockup
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: MoveUpstream
: 70169 (view as bug list)
Depends On:
Blocks: 82777
  Show dependency treegraph
 
Reported: 2001-09-20 09:18 EDT by Michael Schwendt
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-13 00:57:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86.0.log (21.81 KB, text/plain)
2001-09-20 09:18 EDT, Michael Schwendt
no flags Details
XF86Config-4 (2.01 KB, text/plain)
2001-09-20 09:19 EDT, Michael Schwendt
no flags Details
/etc/X11/xdm/Xservers (501 bytes, text/plain)
2001-09-20 09:20 EDT, Michael Schwendt
no flags Details
lspci -vv ; lspci -vvn (10.23 KB, text/plain)
2001-09-20 09:21 EDT, Michael Schwendt
no flags Details

  None (edit)
Description Michael Schwendt 2001-09-20 09:18:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010913

Description of problem:
When switching screen resolution from 1024x768 to 800x600 (or vice versa)
while running kwintv (from Powertools 7.1), this is very likely to cause a
server deadlock, i.e. black screen and keyboard being killed.



Version-Release number of selected component (if applicable):
XFree86-4.1.0-3, see below


How reproducible:
Always

Steps to Reproduce:
1. Start "kwintv", no matter whether full screen or small window.
2. Press CTRL+ALT+"+" or CTRL+ALT+"-" to toggle screen resolution.
3. (repeat step 2 until screen turns black and X is dead)


Actual Results:  Screen turns black. No further keyboard input possible.
Sound keeps playing.

Expected Results:  Switch screen resolution without problems, no matter how
often.


Additional info:

Version of Red Hat Linux is Seawolf plus packages from Rawhide (merely to
get ext3 fs, but also XFree 4.1.0 because it is the same with pristine
Seawolf). In particular:

$ uname -mr
2.4.9-0.5 i686

$ rpm -qa | egrep ^XFree86\|^glibc\|^Mesa | sort
Mesa-3.4.2-7
Mesa-devel-3.4-13
Mesa-glut-3.0-4
XFree86-100dpi-fonts-4.1.0-3
XFree86-4.1.0-3
XFree86-75dpi-fonts-4.1.0-3
XFree86-devel-4.1.0-3
XFree86-libs-4.1.0-3
XFree86-tools-4.1.0-3
XFree86-xf86cfg-4.1.0-3
XFree86-xfs-4.1.0-3
glibc-2.2.4-14
glibc-common-2.2.4-14
glibc-devel-2.2.4-14
Comment 1 Michael Schwendt 2001-09-20 09:18:43 EDT
Created attachment 32198 [details]
XFree86.0.log
Comment 2 Michael Schwendt 2001-09-20 09:19:15 EDT
Created attachment 32199 [details]
XF86Config-4
Comment 3 Michael Schwendt 2001-09-20 09:20:08 EDT
Created attachment 32200 [details]
/etc/X11/xdm/Xservers
Comment 4 Michael Schwendt 2001-09-20 09:21:37 EDT
Created attachment 32201 [details]
lspci -vv ; lspci -vvn
Comment 5 Michael Schwendt 2002-12-28 07:50:43 EST
Reproducible with xawtv and Phoebe beta.
Comment 6 Mike A. Harris 2003-04-15 04:40:58 EDT
Please report this problem upstream to XFree86.org at http://bugs.xfree86.org

I'm hoping that by doing this, one of the numerous developers upstream will
likely investigate the issue and fix it, in which case we can backport any
fixes that come out of it.  This would in effect accelerate the time to a
solution greatly.

If you do so, please include the upstream bug report URL here so I can track it.
Comment 7 Mike A. Harris 2003-04-15 05:06:00 EDT
*** Bug 70169 has been marked as a duplicate of this bug. ***
Comment 9 Mike A. Harris 2006-07-21 17:49:16 EDT
The XFree86 upstream bug is still in open state and has not had any
responses for almost 3 years.  We've switched from XFree86 to X.Org
for 5 OS releases now, so closing this as fixed in Fedora development.
If the problem still exists in rawhide, file a bug in the X.Org bug
tracker, which is where current active development is taking place.

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.