Bug 53867 - (MGA 400 AGP) Losing keyboard focus and/or VC while switching to virtual console
Summary: (MGA 400 AGP) Losing keyboard focus and/or VC while switching to virtual console
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-20 13:33 UTC by Michael Schwendt
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-11 16:59:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2001-09-20 13:33:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010913

Description of problem:
With regard to bug #51615, this is almost the same with Matrox Millennium
G400 AGP. When switching to a virtual console while X server is starting
(or when restart is forced via CTRL+ALT+BACKSPACE), it can happen that
KDM's login screen comes up and keyboard input is impossible because the
hidden virtual console has keyboard focus. Pressing CTRL+ALT+F4 then
restores X to a working kdm.

Version-Release number of selected component (if applicable):
XFree86-4.1.0-3, see bug #53866 for details.

How reproducible:
Always

Steps to Reproduce:
I've chosen "every time" because it is quite easy to reproduce this. One
just needs to hammer on CTRL+ALT+F1 while X server starts.

1. In X Windows (running kdm), press CTRL+ALT+BACKSPACE.
2. Immediately hit CTRL+ALT+F1 many times in a row.
3. Observe how kdm login screen comes up, but keyboard focus is gone.
4. Press CTRL+ALT+F4 (depending on how many VC's you have) to restore the X
session to a working keyboard.


Actual Results:  Virtual console has keyboard focus while X kdm login
screen is displayed.

Expected Results:  X kdm login session ought to have keyboard focus.

Additional info:

See bug #53866 for system config details.

Comment 1 Michael Schwendt 2001-10-16 14:13:22 UTC
Still the case with 4.1.0-4.

Comment 2 Mike A. Harris 2002-03-11 06:56:03 UTC
What exact kernel are you using?


Comment 3 Michael Schwendt 2002-03-11 10:08:11 UTC
The config that _was_ accurate for this bug is mentioned/linked in the
"Version-Release" line above.

With fully updated Enigma it is close to 100% reproducible:

  $ rpm -q kernel XFree86 redhat-release
  kernel-2.4.9-31
  XFree86-4.1.0-15
  redhat-release-7.2-1

With Raw Hide 20020309 it _works for me_ so  far (XFree86 4.2.0-6.32, kernel
2.4.17-0.18). While I seem unable to reproduce these VC switching bugs there, it
can happen that I lose the X Server completely (i.e. no X process anymore, no
log info) when hitting CTRL+ALT+F1 while the server restarts. Same as hitting
CTRL+ALT+BACKSPACE a second or third time before the X server has restarted.
This has a reproducibility of approx. 50%.

Comment 4 Mike A. Harris 2002-11-11 04:04:19 UTC
Is this problem present in Red Hat Linux 8.0 with all erratum updates
applied?  If so, please attach your X server log and config file.

Comment 5 Michael Schwendt 2002-11-11 13:32:57 UTC
No, have been unable to reproduce this with Psyche so far.


Comment 6 Mike A. Harris 2002-11-11 16:59:32 UTC
Closing as working in CURRENTRELEASE (8.0)


Note You need to log in before you can comment on or make changes to this bug.