Bug 58313 - hard-coding optimization flags in patch is obnoxious
hard-coding optimization flags in patch is obnoxious
Status: CLOSED DUPLICATE of bug 53909
Product: Red Hat Raw Hide
Classification: Retired
Component: tcltk (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-13 23:53 EST by Jonathan Kamens
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-03 10:28:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-01-13 23:53:27 EST
It's really obnoxious to hard-code build flags such as -O2 in a patch in the
source RPM instead of using RPM_OPT_FLAGS or some other standard mechanism.  I'm
speaking, in particular of the lines that have "-O2" on them in
tcl-8.3.3-makecfg.patch in the current tcltk Rawhide package.  Doing this amkes
it difficult for people to recompile a package with debugging enabled to track
down problems (e.g., like the expect coredump I'm working on tracking down right
now).
Comment 1 Jens Petersen 2002-12-03 10:28:00 EST
The makecfg patches should be out of the next package release.
Comment 2 Jens Petersen 2002-12-10 20:17:37 EST
Should be fixed in tcltk-8.3.5-76 and later.

*** This bug has been marked as a duplicate of 53909 ***

Note You need to log in before you can comment on or make changes to this bug.