Bug 53947 - /usr/lib/sasl/ (ab)used as a config dir
/usr/lib/sasl/ (ab)used as a config dir
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cyrus-sasl (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Conklin
Brian Brock
:
: 62991 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-23 22:26 EDT by Andrew Bartlett
Modified: 2008-02-28 11:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 11:56:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Bartlett 2001-09-23 22:26:14 EDT
Description of Problem:
cyrus-sasl uses /usr/lib/sasl/ as a configuration directory, in voilation
of the FHS.  (/usr/lib is for platform specific binaries)

Version-Release number of selected component (if applicable):
1.5.24-17, but this also affects all the applications that place *their*
configuraion files here.  Rawhide package appears not to have changed this.

How Reproducible:
Install cyrus-sasl and an applicaion configured to use it (like sendmail).

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:
/usr/lib/sasl used as config dir

Expected Results:
/etc/sasl used as configuration dir, much like /etc/pam.d

Additional Information:
This prevents the mounting of /usr off a remote system and voilates the
FHS.
Comment 1 Chris Ricker 2003-01-10 02:07:05 EST
*** Bug 62991 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2006-08-07 15:38:59 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 3 Andrew Bartlett 2006-08-09 02:14:50 EDT
Still an issue in FC5
Comment 4 Till Maas 2008-01-09 07:48:42 EST
/usr/lib/sasl2/smtp.conf still exists.
Comment 5 Steve Conklin 2008-02-28 11:56:58 EST
/usr/lib/sasl2/smtp.conf (and /usr/lib/sasl/smtp.conf) are installed by the
postfix package, not cyrus-sasl.

Also, the file /usr/lib/sasl2/Sendmail.conf is installed by the sendmail package.

The following changelog entry for cyrus-sasl indicates that if those
applications move the config files, they will be found by cyrus-sasl:

2006-04-19  Alexey Melnikov <alexey.melnikov@isode.com>
        * configure.in: Search for application configuration
          files in /usr/lib/sasl2 by default and fall back to
          /etc/sasl2 if not found.

Note You need to log in before you can comment on or make changes to this bug.