Bug 539740 - does not list mi nic eth0
Summary: does not list mi nic eth0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: iptraf
Version: 12
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Nikola Pajkovsky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 576104
TreeView+ depends on / blocked
 
Reported: 2009-11-20 22:36 UTC by Guillermo Gómez
Modified: 2014-02-02 22:13 UTC (History)
4 users (show)

Fixed In Version: iptraf-3.0.1-10.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 576104 (view as bug list)
Environment:
Last Closed: 2010-04-10 10:23:27 UTC
Type: ---


Attachments (Terms of Use)
iptraf not listing wlan0, nor eth0 (65.31 KB, image/png)
2009-12-10 17:44 UTC, Guillermo Gómez
no flags Details
0001-fix-strcpy-overlap-memory.patch (639 bytes, patch)
2010-03-17 16:39 UTC, Nikola Pajkovsky
no flags Details | Diff

Description Guillermo Gómez 2009-11-20 22:36:47 UTC
Description of problem:

iptraf does not list the ethernet nic (eth0 in my case).

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. su -
2. iptraf
3. ip traffic monitor

  
Actual results:

Lists 
 All interfaces
 lo

Expected results:
 All interfaces
 eth0
 lo


Additional info:

Just discovered that it does not list my wifi nic either.

Comment 1 Nikola Pajkovsky 2009-12-10 10:33:48 UTC
strange I cannot reproduce it.

ip traffic monitor does not exist

try ifconfig eth0 up and than run again iptraf

Comment 2 Guillermo Gómez 2009-12-10 14:03:15 UTC
same results, the nic is up and configured. it also happens with wlan0.

ip traffic monitor i mean > run iptraf, select ip traffic monitor (m), select interface (list appears, does not show eth0 nor wlan0)

[root@movix ~]# uname -r
2.6.31.6-145.fc12.x86_64
[root@movix ~]# rpm -q iptraf
iptraf-3.0.1-8.fc12.x86_64
[root@movix ~]# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:1B:38:72:A6:06  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:18 

noticed its just a listing problem, when packets goes through the interface, iptraf shows the name of the interface correctly (eth0, wlan0).

Comment 3 Nikola Pajkovsky 2009-12-10 16:00:25 UTC
I cannot reproduce even on x86_64. I have only newer kernel.

[root@nec-em18 ~]# uname -r
2.6.31.6-162.fc12.x86_64
[root@nec-em18 ~]# rpm -q iptraf
iptraf-3.0.1-8.fc12.x86_64
[root@nec-em18 ~]# ifconfig | egrep "eth|lo"
eth0      Link encap:Ethernet  HWadr 00:16:17:55:47:C0  
eth1      Link encap:Ethernet  HWadr 00:16:17:55:47:C1  
eth2      Link encap:Ethernet  HWadr 00:04:23:C0:07:DE  
lo           Link encap:loop back

Comment 4 Guillermo Gómez 2009-12-10 17:44:23 UTC
Created attachment 377538 [details]
iptraf not listing wlan0, nor eth0

Just to make it graphic.

Comment 5 Nikola Pajkovsky 2009-12-14 10:28:01 UTC
update your kernel. This should help. I have same issue with 2.6.31.5-127.fc12.x86_64

Comment 6 Guillermo Gómez 2009-12-15 15:14:27 UTC
(In reply to comment #5)
> update your kernel. This should help. I have same issue with
> 2.6.31.5-127.fc12.x86_64  

Still, with 

# uname -r
2.6.31.6-166.fc12.x86_64

same results :(

Comment 7 Nikola Pajkovsky 2010-01-06 10:56:10 UTC
send me your ifconfig -a

Comment 8 Guillermo Gómez 2010-01-06 20:35:20 UTC
g# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:1B:38:72:A6:06  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:18 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:23 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1867 (1.8 KiB)  TX bytes:1867 (1.8 KiB)

vboxnet0  Link encap:Ethernet  HWaddr 0A:00:27:00:00:00  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

virbr0    Link encap:Ethernet  HWaddr BA:82:D9:17:63:72  
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:3584 (3.5 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:1E:4C:6B:DB:7E  
          inet addr:200.109.190.122  Bcast:200.109.191.255  Mask:255.255.224.0
          inet6 addr: fe80::21e:4cff:fe6b:db7e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:395669 errors:0 dropped:0 overruns:0 frame:0
          TX packets:364443 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:234455729 (223.5 MiB)  TX bytes:37416118 (35.6 MiB)

wmaster0  Link encap:UNSPEC  HWaddr 00-1E-4C-6B-DB-7E-80-3E-00-00-00-00-00-00-00-00  
          UP RUNNING  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

Comment 9 Jan Bušta 2010-01-14 17:52:38 UTC
I have the same problem as described after upgrading from F11 to F12, kernel 2.6.31.9-174.fc12.x86_64. I've not tested it, but it's can be due to using NetworkManager?

Comment 10 Guillermo Gómez 2010-01-17 18:22:51 UTC
(In reply to comment #9)
> I have the same problem as described after upgrading from F11 to F12, kernel
> 2.6.31.9-174.fc12.x86_64. I've not tested it, but it's can be due to using
> NetworkManager?    

I dont think so, however i tested stoping NetworkManager, manually configuring my Nic eth0 and still getting the same results.

$ uname -r
2.6.31.9-174.fc12.x86_64

NM should not interfere with iptraf operations.

Comment 11 Jan Bušta 2010-02-01 17:20:05 UTC
Any news, always the same using the kernel 2.6.31.12-174.2.3.fc12.x86_64 and iptraf-3.0.1-8.fc12.x86_64.

Comment 12 Guillermo Gómez 2010-03-14 20:44:23 UTC
No news, still same behaviour:

[gomix@movix ~]$ uname -r
2.6.32.9-70.fc12.x86_64
[gomix@movix ~]$ iptraf -v

IPTraf Version 3.0.1
Copyright (c) Gerard Paul Java 1997-2004

Comment 13 Nikola Pajkovsky 2010-03-15 09:23:25 UTC
I've made a fork. If you have a time try it compile and run it. If this not work try to use *iptraf -u* this should help you.

https://fedorahosted.org/releases/i/p/iptraf-ng/iptraf-ng-1.0.1.tar.gz

Comment 14 Jan Bušta 2010-03-15 17:25:41 UTC
I've problem with compiling this code, see:

make  all-recursive
make[1]: Entering directory `/home/honza/tmp/wq/iptraf-ng-1.0.1'
Making all in support
make[2]: Entering directory `/home/honza/tmp/wq/iptraf-ng-1.0.1/support'
/bin/sh ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..    -Wall -Werror -std=gnu99 -pedantic -g -O2 -MT libtextbox_la-listbox.lo -MD -MP -MF .deps/libtextbox_la-listbox.Tpo -c -o libtextbox_la-listbox.lo `test -f 'listbox.c' || echo './'`listbox.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -Wall -Werror -std=gnu99 -pedantic -g -O2 -MT libtextbox_la-listbox.lo -MD -MP -MF .deps/libtextbox_la-listbox.Tpo -c listbox.c  -fPIC -DPIC -o .libs/libtextbox_la-listbox.o
cc1: warnings being treated as errors
listbox.c: In function ‘tx_operate_listbox’:
listbox.c:108: error: format ‘%d’ expects type ‘int’, but argument 4 has type ‘size_t’
listbox.c:108: error: format ‘%d’ expects type ‘int’, but argument 4 has type ‘size_t’
make[2]: *** [libtextbox_la-listbox.lo] Error 1
make[2]: Leaving directory `/home/honza/tmp/wq/iptraf-ng-1.0.1/support'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/honza/tmp/wq/iptraf-ng-1.0.1'
make: *** [all] Error 2

Comment 15 Nikola Pajkovsky 2010-03-15 22:34:50 UTC
hmmm, morning better than evening. If you have a time join iptraf-ng@irc.freenode.net. We can find some solution.

Comment 16 Nikola Pajkovsky 2010-03-17 16:39:22 UTC
Created attachment 400824 [details]
0001-fix-strcpy-overlap-memory.patch

I have a good news everyone. I found a problem in source code why is not NIC listed. Thanks to Jan. Patch is attached if you want to look and here you have a build: http://koji.fedoraproject.org/koji/taskinfo?taskID=2059230

Comment 17 Nikola Pajkovsky 2010-03-22 08:37:08 UTC
nobody wants to test it?

Comment 18 Fedora Update System 2010-03-22 09:14:14 UTC
iptraf-3.0.1-10.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/iptraf-3.0.1-10.fc12

Comment 19 Fedora Update System 2010-03-22 09:22:55 UTC
iptraf-3.0.1-10.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/iptraf-3.0.1-10.fc13

Comment 20 Mihai Harpau 2010-03-22 14:40:56 UTC
With iptraf-3.0.1-10.fc12 I could see now all network interfaces: eth0, wlan0, lo etc. So bug is fixed. Many thanks!

Comment 21 Guillermo Gómez 2010-03-22 15:04:29 UTC
:) i'll test it asap

Comment 22 Guillermo Gómez 2010-03-22 23:02:53 UTC
Confirmed, the bug is fixed in my F12 x86_64 , :D

Comment 23 Fedora Update System 2010-03-23 23:27:18 UTC
iptraf-3.0.1-10.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2010-03-23 23:30:40 UTC
iptraf-3.0.1-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update iptraf'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/iptraf-3.0.1-10.fc12

Comment 25 Fedora Update System 2010-04-10 10:23:20 UTC
iptraf-3.0.1-10.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.