Bug 53988 - up2date fails to install xfree 3.3.6-38
up2date fails to install xfree 3.3.6-38
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 54007 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-24 21:22 EDT by Alton Weeks
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-04 13:44:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alton Weeks 2001-09-24 21:22:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-7.0.8 i586)

Description of problem:
When ever I try to install the new Xfree86 packages from up2date I receive
this error:

Test install failed because of package conflicts:
file /usr/X11R6/lib/modules/pex5.so from install of Xfree86-3DLabs
conflicts with file from package Xfree86-l128-33.6-33

I do not have an option to install the l128 update. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. up2date	
2. Select the Xfree86 packages
3.
	

Additional info:
Comment 1 Mike A. Harris 2001-09-24 22:17:31 EDT
This is the result of really bad packaging decisions for the original
XFree86 packages.  Multiple packages contain the same physical files,
and RPM allows packages sharing a common file to be installed
simultaneously if the files are identical.  IMHO that sucks.

The result is that you cannot upgrade *one* of the packages, since that
will change the common shared file.  Instead, you need to update *all*
packages simultaneously ala:  rpm -Fvh *.rpm

Since the packages are thus dependant on each other for the shared
file, they won't update properly, but since they aren't explicitly
flagged by RPM as dependants, up2date fails.

The proper solution is having the new RPM packages obsolete the old ones
entirely using some mechanism.  It is quite complex a matter however, and
I am not entirely sure it is worthwhile use of resources to do so.

I will leave this bug open for consideration if a future erratum of
3.3.6 for 6.2/7.0/7.1 is released.  Please note that the 3.3.6 i128
server is obsolete, and replaced by XFree86 4.x's i128 support.

Xconfigurator --preferxf4 will force the 4.x server to be used, and
it should work fine.

Hope this helps.  Deferring for future consideration...
Comment 2 Mike A. Harris 2001-09-24 23:59:09 EDT
By the way, I wasn't entirely clear above..  if you do indeed want to
use 3.3.6 in RHL 7.0 for I128, you can force the package to install
with RPM, or you can download the updated packages from our ftp
server updates.redhat.com, and apply them with rpm -Fvh *.rpm

I've thought about this a bit more and it is unlikely that fixed
packages will be made available, because I can't see any way to
have fixed packages, and still allow upgrading to 7.1 and later
releases, because the on-cd XFree86 won't know how to deal with
new packages that are done correctly...  I'm still keeping it open
in case someone else has an idea how to fix it that doesn't have
any bad side effects.
Comment 3 Mike A. Harris 2001-09-25 17:12:43 EDT
*** Bug 54007 has been marked as a duplicate of this bug. ***
Comment 4 Mike A. Harris 2001-10-04 13:44:13 EDT
The RPM packaging has been fixed somewhat but I don't believe that there is
a way to have up2date work correctly with these packages.  This is a flaw
in the original pre-up2date packaging.  A very very horrible sick twisted
packaging flaw of immense horribleness.
Comment 5 Mike A. Harris 2001-10-04 13:46:43 EDT
Unfortunately, the solution to this problem that has been done, if released
as erratum would cause future upgrade problems.  Therefore, it is recommended
to upgrade XFree86 via ftp/rpm as a workaround.

Be sure to download all XFree86 packages and do: rpm -Fvh XFree86*.rpm
Comment 6 Alton Weeks 2001-10-04 19:52:18 EDT
Thanks
Comment 7 bil kleb 2001-12-17 10:00:51 EST
I had to force the install, i.e.,

 rpm -Fvh --force XFree86-*.rpm

Note You need to log in before you can comment on or make changes to this bug.