Bug 53990 - Installer crashes after detecting the video card
Installer crashes after detecting the video card
Status: CLOSED DUPLICATE of bug 37592
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-24 23:10 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-25 14:20:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-09-24 23:10:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 4.0)

Description of problem:
During the installation of Redhat 7.1 from hard disk, the installer 
crashes after selecting the packages and after selecting the video card.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start the installation (Hard disk or network. I didn't try CD-ROM)
2.Answer all questions normally
3.
	

Actual Results:  The installer crashed after detecting the video card.

Expected Results:  The installer should start installing the selected 
packages.

Additional info:

The installer crashes after I select the packages and after it identifies 
the video card I have.  I get the following message in the screen (the 
display on the screen will be jumbled):

type read: Operation not permitted
pfd: 11
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...  <= After this, I see <Tab>/<Alt-tab> between
                      elements | <Space> selects : <F12> next screen
unmounting filesystems...
/mnt/runtime/usr
/proc/bus/usb
/mnt/runtime
/dev/pts
/proc
you may sefely reboot your system

<End of message>

This happens with any type of installation (default, expert, nofb, lowres).

I can't get the graphical mode.  Anaconda tries to start, but displays a 
message briefly and installer switches to text mode install.

aic7xxx driver is loaded first.

I have AHA-2940 SCSI card with 3 disks.  Details as follows:

/dev/sda1 FAT32 Win 98
/dev/sdb  Free  For new Linux
/dev/sdc1 FAT32 Installation ISO images

I created /dev/sdb1 for / with approx. 1804 MB and a swap partition of 
approx. 196 MB.

I tried installing the bootloader on /dev/sda and on /dev/sdb1.  Results 
are the same.

Proceeding further, after I select the package groups I want, X probes and 
finds that I have Matrox Millennium video card and the X server is 
XF86_SVGA.  Right after I select OK for this, the installer displays about 
log file and when I select OK, it immediately crashes.

I have the following on Alt+Fn screens (I typed these manually.  Please 
bear with any typos):

Alt+F2 - # prompt (hung)

Alt+F3: (last portion)
------
* got url hd://sdc1:vfat/
* getting ready to spawn shell now
* probing buses
* finished bus probing
* found suggestion of tulip
* found tulip device
* found suggestion of tulip
* found tulip device
* found suggestion of usb-uhci
* found devices justProbe is 0
* going to insmod tulip.o (path is NULL)
* going to insmod raid0.o (path is NULL)
* going to insmod raid1.o (path is NULL)
* going to insmod xor.o (path is NULL)
* going to insmod raid5.o (path is NULL)
* going to insmod msdos.o (path is NULL)
* going to insmod ext3.o (path is NULL)
* looking for usb mouse...
* no IDE floppy device found
* Detected 96M of memory
* Swap attempt of 96M to 192M
* Maximum cylinder is 230
* X is being installed, need to enable server if set

Alt-F4 (last portion)
------
<6>Linux Tulip driver version 0.91.14 (February 20, 2001)
<6>eth0: Digital DS21143 Tulip rev 48 at 0xec00, 00:00:F8:79:11:6C, IRQ 10.
<6>eth0:  EEPROM default media type Autosense.
<6>eth0:  Index #0 - Media 10BaseT (#0) described by a 21142 Serial PHY 
(2) block.
<6>eth0:  Index #1 - Media 10BaseT-FD (#4) described by a 21142 Serial PHY 
(2) block.
<6>eth0:  Index #2 - Media 10Base2 (#1) described by a 21142 Serial PHY 
(2) block.
<6>eth0:  Index #3 - Media AUI (#2) described by a 21142 Serial PHY (2) 
block.
<6>eth0:  Index #4 - Media AUI (#11) described by a 21142 Serial PHY (2) 
block.
<6>eth0: ***WARNING***: No MII transeiver found!
<6>eth0: Digital DS21140 Tulip rev 48 at 0xe480, 00:00:F8:02:44:96, IRQ 10.
<6>eth0:  EEPROM default media type Autosense.
<6>eth0:  Index #0 - Media MII (#11) described by a 21140 MII PHY (1) 
block.
<6>eth0:  MII transceiver #5 config 3100 status 7809 advertising 01e1.
<6>raid0 personality registered as nr 2
<6>raid1 personality registered as nr 3
<6>raid5: measuring checksumming speed
<4>   8regs     :   314.400 MB/sec
<4>   32regs    :   181.600 MB/sec
<4>raid5: using function 8regs (314.400 MB/sec)
<4>raid5 personality regsitered as nr 4
<7>ISO 9660 Extensions: RRIP_1991A
<7>ISO 9660 Extensions: RRIP_1991A
<6>cdrom: open failed.
<6>cdrom: open failed.
<6>cdrom: open failed.
<6>cdrom: open failed.
<6>cdrom: open failed.
<6>cdrom: open failed.
<7>ISO 9660 Extensions: RRIP_1991A
<7>ISO 9660 Extensions: RRIP_1991A
<6>cdrom: open failed.
<6>cdrom: open failed.


I also tried FTP and HTTP installations.  It fails at the same place with 
the only difference in the number that appears "pfd:".  It is 11 in case 
of hard disk install and 15 in case of network install.
Comment 1 Brent Fox 2001-09-25 10:21:10 EDT
What kind of machine is this?
Comment 2 Need Real Name 2001-09-25 14:20:16 EDT
The machine is a Digital (DEC) PC Celebris GL6200 Pentium Pro 200MHz with on-
board 21142 based network card, IDE controller, AHA-2940 SCSI card, on-board 
Matrox Millennium video card (2 MB), on-board ESS1888, 2 USB ports and 96M 
memory.  It also has an additional Digital 21140 network card.
Comment 3 Brent Fox 2001-09-25 15:45:34 EDT
Uh-oh.  I was afraid this might be a Celebris.  The kernel just appears to not
work on those machines.  This is a dupe of bug #37592.

*** This bug has been marked as a duplicate of 37592 ***

Note You need to log in before you can comment on or make changes to this bug.