Bug 53997 - Installer crashes when formatting swap partition
Installer crashes when formatting swap partition
Status: CLOSED DUPLICATE of bug 17791
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-25 05:26 EDT by Philip Le Mesurier
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-25 05:26:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Le Mesurier 2001-09-25 05:26:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
When doing a fresh install the installer successfully formats the / 
partition (1.5GB) and the /boot partiotion (23MB) but crashes while 
formatting the /swap partition (16MB). Dumpfile below.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create/Recreate/Edit partitions outlined above (have tried all 3 of 
these options with various partition sizes). Druid or fdisk (doesn't 
matter which, both lead to the same crash)
2. Accept all the defaults in the following steps (i.e format all 
partitions, MBR, boot linux as default etc)
3. Install all/some/most/a few packages (I've tried all sorts)
4. Wait while it formats the / and /boot partitions
5. Watch it start to format the /swap partition then crash after about 5 
seconds.
	

Actual Results:  Installer crashed and a dump file was created.

Expected Results:  Swap file formatted, packages installed etc.

Additional info:

PC Specs:
AMD Thunderbird 1300, Enhanced 3DNow, 128k L1, 256k L2 OnChip, 200MHz 
System Bus
Microstar MS-6330P2 KTPro2 ATX Athlon SktA Motherboard, VIA KT133
394 Mb SDRam, PC-133
Nvidia GeForce2-MX400 AGP 64 Mb Video Card
20GB Seagate ST320423A IDE Hard Drive
Liteon DVD 12X / 40X CDROM Drive

Anacdump:
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1470, in 
doInstall
    self.fstab.turnOnSwap()
  File "fstab.py", line 408, in turnOnSwap
    isys.swapon (file)
  File "isys.py", line 142, in swapon
    return _isys.swapon (path)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
path: /tmp/swap/hda6

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Brent Fox 2001-09-25 11:03:11 EDT

*** This bug has been marked as a duplicate of 17791 ***

Note You need to log in before you can comment on or make changes to this bug.