Bug 53999 - Relocations fail with RPM 4.0.2
Summary: Relocations fail with RPM 4.0.2
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL: http://cern.ch/loomis/bugs.html
Whiteboard:
Keywords:
: 54995 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-25 10:13 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-25 10:14:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
simple relocatable package (1.26 KB, application/octet-stream)
2001-09-25 10:14 UTC, Need Real Name
no flags Details

Description Need Real Name 2001-09-25 10:13:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
When actually relocating a relocatable package with RPMv4, the 
installation fails.  Specifically, if the prefix in the spec file
is /usr, then using "--prefix /opt" in the rpm installation causes
the file to be written to the FILE "/opt".  If there is more than one
file in the archive, then it tries to write ALL files to "/opt" and
fails.  

If one uses "--prefix /opt/test", then RPMv4 tries to write all files
in the archive to the FILE "/opttest".  Note that the output file name
has been mangled.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. download the rpms from above URL
2. type: "rpm --install --prefix /opt2 rpmbug-0.0.1-1.noarch.rpm"
3. this installs the included file in a FILE named "/opt2"
4. type:"rpm --install --prefix /opt2/test rpmbug2-0.0.1-1.noarch.rpm"
5. this installs the included file in a FILE named "/opt2test".
6. if the archive contains more than one file, then rpm v4 tries to
   write ALL files to one named "/opt2" or "/opt2test"
7. all of this works correctly with rpm v3	

Actual Results:  RPM file tree not relocated, and rpm tries to write all
files to a 
single file.

Expected Results:  RPM should have relocated the entire archive tree.

Additional info:

Comment 1 Need Real Name 2001-09-25 10:14:47 UTC
Created attachment 32558 [details]
simple relocatable package

Comment 2 Jeff Johnson 2001-09-25 14:01:25 UTC
Yup, fixed since rpm-4.0.3-0.6. Try rpm-4.0.3-1.03
from ftp://ftp.rpm.org/pub/rpm/test-4.0.3, or wait
for the final rpm-4.0.3 release in the next week or two.

Comment 3 Jeff Johnson 2001-10-24 02:03:46 UTC
*** Bug 54995 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.