Bug 54995 - rpm -i --prefix not working right
rpm -i --prefix not working right
Status: CLOSED DUPLICATE of bug 53999
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2J
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 21:14 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-23 21:14:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-23 21:14:18 EDT
Description of Problem:

When I install a relocatable package:

$ rpm -qpl log-triggers-4.0.6_2855-1.noarch.rpm 
/opt/foo/store/trigger
/opt/foo/store/trigger/AlertTrigger.py
/opt/foo/store/trigger/CritTrigger.py
/opt/foo/store/trigger/EmergeTrigger.py

with

# rpm -i --prefix=/var/tmp/foo log-triggers-4.0.6_2855-1.noarch.rpm 

I get:

$ rpm -ql log-triggers
/var/tmpfoo
/var/tmp/foo/AlertTrigger.py
/var/tmp/foo/CritTrigger.py
/var/tmp/foo/EmergeTrigger.py

I think the first one (/var/tmpfoo) is broken.

Version-Release number of selected component (if applicable):

4.0, 4.0.2

How Reproducible:

Very.

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:

/var/tmpfoo

Expected Results:

/var/tmp/foo

Additional Information:
Comment 1 Jeff Johnson 2001-10-23 22:03:50 EDT

*** This bug has been marked as a duplicate of 53999 ***

Note You need to log in before you can comment on or make changes to this bug.