Bug 54004 - /etc/init.d/gpm does not use DEVICE correctly
/etc/init.d/gpm does not use DEVICE correctly
Status: CLOSED DUPLICATE of bug 36995
Product: Red Hat Linux
Classification: Retired
Component: gpm (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-25 07:56 EDT by Carl-Johan Kjellander
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-06 15:39:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch to fix /etc/init.d/gpm (280 bytes, patch)
2001-09-25 07:57 EDT, Carl-Johan Kjellander
no flags Details | Diff

  None (edit)
Description Carl-Johan Kjellander 2001-09-25 07:56:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010816

Description of problem:
I think there is a typo in /etc/init.d/gpm. If you try to set
the mouse device in /etc/sysconfig/mouse to something like:

DEVICE=/dev/input/mice

then gpm will still try to use /dev/mouse. The offending lines in
/etc/init.c/gpm are:

	if [ -n "$DEVICE" ]; then
	    DEVICE="/dev/mouse"
	fi

This means that if DEVICE is set to something set it to
/dev/mouse instead. The lines should be:

	if [ -z "$DEVICE" ]; then
		DEVICE="/dev/mouse"
	fi

This means, if DEVICE is NOT set, then set it to /dev/mouse.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set DEVICE to something else than /dev/mouse in /etc/sysconfig/mouse.
2. Start gpm with /etc/init.d/gpm

	

Actual Results:  Gpm uses /dev/mouse as device.

Expected Results:  Gpm should use what you have set DEVICE to in
/ets/sysconfig/mouse.

Additional info:
Comment 1 Carl-Johan Kjellander 2001-09-25 07:57:28 EDT
Created attachment 32559 [details]
A patch to fix /etc/init.d/gpm
Comment 2 Bernhard Rosenkraenzer 2002-01-22 16:33:46 EST

*** This bug has been marked as a duplicate of 36995 ***

Note You need to log in before you can comment on or make changes to this bug.