Bug 36995 - error in /etc/rc.d/init.d/gpm
error in /etc/rc.d/init.d/gpm
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
David Lawrence
:
: 41553 54004 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-21 13:08 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-16 13:56:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-21 13:08:41 EDT
Line 38 of /etc/rc.d/init.d/gpm must be changed from:

 if [ -n "$DEVICE" ]; then

to:

 if [ ! -n "$DEVICE" ]; then

or else "DEVICE=..." in /etc/sysconfig/mouse has no effect.
Comment 1 Martin Wilck 2001-05-16 13:56:33 EDT
Right, I had the same problem. Better yet, 

if [ -z "$DEVICE" ]
...
Comment 2 Preston Brown 2001-06-25 13:18:46 EDT
fixed in 1.19.3-18 and later.
Comment 3 Preston Brown 2001-06-25 13:19:14 EDT
*** Bug 41553 has been marked as a duplicate of this bug. ***
Comment 4 Bernhard Rosenkraenzer 2002-01-22 16:33:40 EST
*** Bug 54004 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.