Bug 54008 - crash when un-archiving bz2 files
Summary: crash when un-archiving bz2 files
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.1k
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-25 13:40 UTC by Ian Beard
Modified: 2005-10-31 22:00 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-11-28 10:46:14 UTC


Attachments (Terms of Use)

Description Ian Beard 2001-09-25 13:40:57 UTC
Description of Problem:
download insight debugger, un-archive (right click) - BANG

Version-Release number of selected component (if applicable):
kde 2.1 explorer

How Reproducible:
un-archive bz2 file

Steps to Reproduce:
1. download bz2 file
2. right click in file manager
3. un-archive

Actual Results:
reduces linux to rubble - scrambles entire disk system

Expected Results:
un-archived files

Additional Information:
Seriously un-impresses

Comment 1 Trond Eivind Glomsrxd 2001-09-25 15:32:51 UTC
That would be a KDE problem, not a bzip2 problem.

Comment 2 Bernhard Rosenkraenzer 2001-11-27 16:41:29 UTC
I can't reproduce this.
What do you mean by "scrambles entire disk system"?
If it's filesystem corruption, chances are your kernel is doing something odd.


Comment 3 Ian Beard 2001-11-28 10:26:34 UTC
Basically, I had to re-install Red Hat. System would not re-boot. Seemed to me 
a file descriptor may have decided to go walkabout and went into the system 
file space. I did this twice, the second time by mistake. Debugging on Linux a 
big joke, so have decided to do my Unix work on Solaris anyway, so have no 
problem anymore. But thanks for letting me know someone was going to look into 
it, kinda unexpected.

Comment 4 Bernhard Rosenkraenzer 2001-11-28 10:45:38 UTC
This sounds like a kernel problem. Please give some details on your hardware 
and configuration, in particular:
IDE or SCSI controller type
Filesystem used




Note You need to log in before you can comment on or make changes to this bug.