This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 540198 - Nautilus file manager non-functional after upgrade from Fedora 10 to Fedora 12
Nautilus file manager non-functional after upgrade from Fedora 10 to Fedora 12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-good (Show other bugs)
12
i386 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 543826 546085 550924 553910 553926 554016 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-22 12:55 EST by Andre Klapper
Modified: 2010-01-18 07:06 EST (History)
10 users (show)

See Also:
Fixed In Version: 0.10.17-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-04 18:41:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andre Klapper 2009-11-22 12:55:45 EST
Description of problem:
Nautilus non-functional after upgrade from Fedora 10 to Fedora 12

How reproducible:
Always (tried twice)

Steps to Reproduce:
1. Update uptodate Fedora 10 to Fedora 12
2. Boot into GNOME
  
Actual results:
Empty desktop: old background image has been correctly restored, but no files are shown on the Desktop (though they still exist according to the terminal), plus the right-click menu is never shown.
Two nautilus processes are running:
$:andre\> ps ax | grep nautilus
 2350 ?      S   0:00 nautilus
 2353 ?      S   0:00 nautilus
 2366 pts/0  R+  0:00 grep nautilus
Also, going to "Places" and choosing any folder does not bring up a file manager window.

Expected results:
Working desktop

Hardware:
Lenovo Thinkpad T61 (got Nouveau only to work by using "nomodeset" as boot parameter)
Comment 1 Andre Klapper 2009-11-22 18:19:44 EST
FIRST OF ALL: THIS IS FIXED, SEE BELOW.
Feel free to close as INVALID or whatever, but cannot hurt to have it documented here. :-)



  package-cleanup --dupes
and
  package-cleanup --problems
come up with nothing.

I did not mention in my initial posting here that I cannot run
* rhythmbox
* totem
* brasero
because I thought that this is unrelated to this issue.
However, after finding similar problem descriptions at 
http://forums.fedoraforum.org/showthread.php?p=1293399 and http://osdir.com/ml/fedora-list/2009-11/msg01664.html it might be related.
The first link mentions the theory "nautilus starts up and loads brasero-nautilus, this uses the brasero library and tries to initialize gstreamer".

Here is the output of that issue. It is exactly the same output for all applications mentioned in the list before:

$:andre\> totem
Warning: Unable to create "trees" RDF storage.
Performance can be improved by upgrading librdf.
sys:1: Warning: cannot register existing type `GstSignalProcessor'
sys:1: Warning: g_once_init_leave: assertion `initialization_value != 0' failed
sys:1: Warning: g_type_register_static: assertion `parent_type > 0' failed
(totem:2525): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

After that it hangs forever.

Also note that after choosing to restart I always got the popup "Application still running: File Manager - No answer"


SOLUTION:

So after I yum erase'd
gstreamer-plugins-ugly-0.10.13-1.fc12.i686
gstreamer-plugins-bad-0.10.16-1.fc12.i686
gstreamer-plugins-bad-devel-0.10.16-1.fc12.i686
gstreamer-plugins-bad-extras-0.10.16-1.fc12.i686
and rebooted, my files and folders on the Desktop were finally shown plus there is only one nautilus process running.

Don't know exactly which of the files was the one to blame.
Comment 2 Tomáš Bžatek 2009-11-23 05:52:14 EST
Thanks Andre, this is really useful. I'll leave this bugreport open for a while, I suspect lots of abrt bugs (whose stacktraces are usually full of question marks) point to the same issue.
Comment 3 Rohan Dhruva 2009-12-03 05:04:32 EST
*** Bug 543826 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2009-12-04 06:02:32 EST
gstreamer-plugins-good-0.10.17-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gstreamer-plugins-good-0.10.17-3.fc12
Comment 5 Fedora Update System 2009-12-04 18:41:14 EST
gstreamer-plugins-good-0.10.17-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Andre Klapper 2009-12-05 10:34:40 EST
Yes, this fixed it for me.
No problems after reinstalling the packages in comment 1 and rebooting.
Comment 7 Tomáš Bžatek 2009-12-11 08:41:08 EST
*** Bug 546085 has been marked as a duplicate of this bug. ***
Comment 8 Tomáš Bžatek 2010-01-11 08:17:02 EST
*** Bug 554016 has been marked as a duplicate of this bug. ***
Comment 9 Andy Lawrence 2010-01-11 08:30:04 EST
Even with gstreamer-plugins-good-0.10.17-3.fc12 I still had to remove the below packages to get nautilus to start.

gstreamer-plugins-ugly-0.10.13-1.fc12.i686
gstreamer-plugins-bad-0.10.16-1.fc12.i686
gstreamer-plugins-bad-devel-0.10.16-1.fc12.i686
gstreamer-plugins-bad-extras-0.10.16-1.fc12.i686
Comment 10 Tomáš Bžatek 2010-01-11 09:20:55 EST
*** Bug 553910 has been marked as a duplicate of this bug. ***
Comment 11 schuster.bernhard 2010-01-11 12:49:59 EST
Still persisting, Fedora 12...
Comment 12 schuster.bernhard 2010-01-11 13:28:42 EST
Ok, I got it working aswell, by removing gstreamer-plugins-ugly, -bad, -bad-extra

Did anybody allready file bugs against them? And if where did you do so and does omebody take care about?
Comment 13 Tomáš Bžatek 2010-01-15 04:16:21 EST
*** Bug 550924 has been marked as a duplicate of this bug. ***
Comment 14 Scott Castaline 2010-01-17 17:48:51 EST
Have you tried a forced relabeling by SELinux on reboot? That seemed to have fixed the same symptoms that I had after an update done to F12. I lost all of my desktop icons and nautilus would not run. After rebooting with the relabel set, everything worked again.
Comment 15 Andy Lawrence 2010-01-17 17:54:38 EST
Yes, I relabel with no luck. Not sure which package but I removed all of the following, then all was good.

gstreamer-plugins-ugly-0.10.13-1.fc12.i686
gstreamer-plugins-bad-0.10.16-1.fc12.i686
gstreamer-plugins-bad-devel-0.10.16-1.fc12.i686
gstreamer-plugins-bad-extras-0.10.16-1.fc12.i686
Comment 16 schuster.bernhard 2010-01-17 19:57:43 EST
*** Bug 553926 has been marked as a duplicate of this bug. ***
Comment 17 Scott Castaline 2010-01-17 20:57:16 EST
I just verified that I do have all of those packages although I have the x86_64 builds, so I don't know if that makes a difference. Don't know what to tell you on that.
Comment 18 schuster.bernhard 2010-01-17 21:42:42 EST
It does not, I have x86_64 Fedora 12 up and running and after I removed the pending x86_64 packages and a re-login it worked just fine again
Comment 19 Scott Castaline 2010-01-17 22:33:33 EST
I do notice one difference, I don't have any of the devel packages for gstreamer. That shouldn't matter as all that is is the source code of the respective package, which you only need if you compile software that requires the inclusion of that package into its source at compile time. You could just install one at a time to see which one is causing this to happen. You could have a conflict in some obscure configuration file.
Comment 20 schuster.bernhard 2010-01-18 07:06:47 EST
The question is rather what has been done in order to make gstreamer-plugins-good work, as this big was initially reported against gstreamer-plugins-good, and then search for the responsible for the bad/bad-extras/ugly plugins.

Note You need to log in before you can comment on or make changes to this bug.