This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 540237 - preupgrade fails to resume an interrupted upgrade that uses rpmfusion repos
preupgrade fails to resume an interrupted upgrade that uses rpmfusion repos
Status: CLOSED DUPLICATE of bug 538118
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-22 16:06 EST by Chris Rankin
Modified: 2014-01-21 18:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-22 16:13:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Rankin 2009-11-22 16:06:11 EST
Description of problem:
Started preupgrade from scratch, but had to stop it part way through due to lack of time. When I tried to resume the preupgrade later, it crashed when trying to process meta-data from one of the rpmfusion repositories.

Version-Release number of selected component (if applicable):


How reproducible:
Every time so far. Restarting from the beginning again seems the only workaround.

Steps to Reproduce:
1. Install packages from rpmfusion (all ffmpeg packages?) into Fedora 11.
2. Run preupgrade.
3. Cancel preupgrade while half-way through downloading new F12 packages.
4. Restart preupgrade.
  
Actual results:
preupgrade crashes at "Step 1" while trying to process upgrade information from the rpmfusion repositories. (I.e. the step before downloading the installers.)

Expected results:
The upgrade process would continue from where it left off.

Additional info:
I have already successfully used preupgrade to upgrade a similar system to F12, expect that I had enough time to let it run to completion on that occasion. (I.e. I didn't need to interrupt it.)
Comment 1 Chris Rankin 2009-11-22 16:13:12 EST
Oh, it's been reported already ;-).

FWIW, the system experiencing this problem was upgraded from F10 to F11 via preupgrade.

*** This bug has been marked as a duplicate of bug 538118 ***

Note You need to log in before you can comment on or make changes to this bug.