Bug 540361 - publican.cfg variables do not override book_info.xml
publican.cfg variables do not override book_info.xml
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
high Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
: 540750 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-23 01:57 EST by Christopher Curran
Modified: 2010-11-23 23:19 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 540750 (view as bug list)
Environment:
Last Closed: 2009-11-24 18:06:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christopher Curran 2009-11-23 01:57:54 EST
Description of problem:
Given the existence of the publican.cfg file publican should accept arbitrary and non-latin names, products and versions. The book_info.xml file should allow any value in productnumber, title, edition, subtitle and so on.

Version-Release number of selected component (if applicable):
1.1

How reproducible:
Every time. 

Steps to Reproduce:
1. Create a book
2. Put something funky in the edition (for example: 愛) and then configure a numerical version in the publican config file (for example: 1).
3. book breaks (see "results").
  
Actual results:
Invalid format for version. Value (愛) does not conform to constraint ([^0-9.]) at /usr/bin/publican line 362


Expected results:
These constraints should be removed if there is a value present in the configuration file.

The book should build and output an RPM with version 1 and a product with edition 愛.

Additional info:
Edition Beta/Alpha and prerelease should work. Product numbers and editions should support latin characters, non latin characters and punctuation.
Comment 1 Jeff Fearn 2009-11-23 22:02:28 EST
*** Bug 540750 has been marked as a duplicate of this bug. ***
Comment 2 Jeff Fearn 2009-11-23 22:20:05 EST
tested building and packaging with the following settings.

$ grep edition en-US/Book_Info.xml publican.cfg 
en-US/Book_Info.xml:    <edition>愛</edition>
publican.cfg:edition: 1.2

Built and packaged correctly with o error messages. Please supply a link to your source so we can check it for oddities.
Comment 3 Christopher Curran 2009-11-24 18:38:44 EST
This works in 1.2. It just affected 1.1. Fixed.

Note You need to log in before you can comment on or make changes to this bug.