Bug 540681 - 2.6.31.5-127.fc12.x86_64 Oops and bootup hangs during transition to login screen on HP 6390p laptop
Summary: 2.6.31.5-127.fc12.x86_64 Oops and bootup hangs during transition to login scr...
Keywords:
Status: CLOSED DUPLICATE of bug 540218
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 12
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-23 22:55 UTC by Bradley Scalio
Modified: 2009-11-25 20:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 540218
Environment:
Last Closed: 2009-11-25 20:09:31 UTC


Attachments (Terms of Use)

Description Bradley Scalio 2009-11-23 22:55:49 UTC
Description of problem:
   After installation of Fedora12 from DVD media which passed the Self-Test, on first-boot, kernel crashes during the transition from plymouth to gdm-greeter (as Fedora logo appears but prior to gdm login screen) and hangs requiring a hard reboot.  This only is occurring on the HP 6930p laptop, tried an install on a few other machines and all seem okay, including other HP laptops.

Version-Release number of selected component (if applicable):
2.6.31.5-127.fc12.x86_64

How reproducible:
Every time with

Steps to Reproduce:
1. Install F12 64bit using default install options
2. Reboot after successful install
3. After first-boot options enter and transition to gdm-greeter system hangs
  
Have not tried a 32bit install.


Actual results:


Expected results:


Additional info:

Kernel Oops:
------------[ cut here ]------------
WARNING: at arch/x86/mm/ioremap.c:219 __ioremap_caller+0x145/0x30e() (Tainted: G        W )
Hardware name: HP EliteBook 6930p
Modules linked in:
Pid: 1, comm: swapper Tainted: G        W  2.6.31.5-127.fc12.x86_64 #1
Call Trace:
[<ffffffff81051694>] warn_slowpath_common+0x84/0x9c
[<ffffffff810516c0>] warn_slowpath_null+0x14/0x16
[<ffffffff81034c6f>] __ioremap_caller+0x145/0x30e
[<ffffffff810e2356>] ? free_unmap_vmap_area_noflush+0x3c/0x7c
[<ffffffff812222c7>] ? alloc_iommu+0x1de/0x253
[<ffffffff81034f1a>] ioremap_nocache+0x17/0x19
[<ffffffff812222c7>] alloc_iommu+0x1de/0x253
[<ffffffff8173c8ea>] ? dmar_table_init+0x10d/0x34d
[<ffffffff8173c960>] dmar_table_init+0x183/0x34d
[<ffffffff81722ff6>] enable_IR_x2apic+0x12/0x1ce
[<ffffffff81720a2f>] native_smp_prepare_cpus+0x12d/0x361
[<ffffffff8105496c>] ? do_wait+0x299/0x2d7
[<ffffffff817145bb>] kernel_init+0x84/0x273
[<ffffffff81012daa>] child_rip+0xa/0x20
[<ffffffff81714537>] ? kernel_init+0x0/0x273
[<ffffffff81012da0>] ? child_rip+0x0/0x20
---[ end trace a7919e7f17c0a726 ]---

Comment 1 Bradley Scalio 2009-11-23 23:59:10 UTC
some FYI info:

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:03.2 IDE interface: Intel Corporation Mobile 4 Series Chipset PT IDER Controller (rev 07)
00:03.3 Serial controller: Intel Corporation Mobile 4 Series Chipset AMT SOL Redirection (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
02:00.0 Network controller: Intel Corporation Wireless WiFi Link 5300
85:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 06)
85:09.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 25)
85:09.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev bb)
85:09.3 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ff)

Comment 2 Bradley Scalio 2009-11-25 20:09:31 UTC
Been adding to 540218 and that bug is a dup but predates this opening FYI

*** This bug has been marked as a duplicate of bug 540218 ***


Note You need to log in before you can comment on or make changes to this bug.